summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-04 08:39:39 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-04 08:39:39 +0000
commit85f90ab2aaddc75d9126e6edd6d2562bb33434e6 (patch)
tree0c9cd9524ad527df34531d9b1afad5cee0b8f57e /app-text/libmwaw
parentebuild improvements (bug #515986) (diff)
downloadgentoo-2-85f90ab2aaddc75d9126e6edd6d2562bb33434e6.tar.gz
gentoo-2-85f90ab2aaddc75d9126e6edd6d2562bb33434e6.tar.bz2
gentoo-2-85f90ab2aaddc75d9126e6edd6d2562bb33434e6.zip
Version bump. Bug #538188.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/ChangeLog9
-rw-r--r--app-text/libmwaw/libmwaw-0.3.4.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-text/libmwaw/ChangeLog b/app-text/libmwaw/ChangeLog
index 3c5ca4ed7ee4..736a1388398b 100644
--- a/app-text/libmwaw/ChangeLog
+++ b/app-text/libmwaw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libmwaw
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.14 2014/10/10 20:17:48 maekke Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.15 2015/02/04 08:39:39 mgorny Exp $
+
+*libmwaw-0.3.4 (04 Feb 2015)
+
+ 04 Feb 2015; Michał Górny <mgorny@gentoo.org> +libmwaw-0.3.4.ebuild:
+ Version bump. Bug #538188.
10 Oct 2014; Markus Meier <maekke@gentoo.org> libmwaw-0.3.1.ebuild:
add ~arm, bug #520692
diff --git a/app-text/libmwaw/libmwaw-0.3.4.ebuild b/app-text/libmwaw/libmwaw-0.3.4.ebuild
new file mode 100644
index 000000000000..0d9bb550f8e9
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/libmwaw-0.3.4.ebuild,v 1.1 2015/02/04 08:39:39 mgorny Exp $
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46:=
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}