summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-09-16 09:43:47 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-09-16 09:43:47 +0000
commitd069e32c2805ad78806254564ac9a6bb680d180b (patch)
tree83ce196ab3bd2f86ddf7bb074af4b1137dfaf394 /app-text/htmlinc
parentfixed typo (diff)
downloadgentoo-2-d069e32c2805ad78806254564ac9a6bb680d180b.tar.gz
gentoo-2-d069e32c2805ad78806254564ac9a6bb680d180b.tar.bz2
gentoo-2-d069e32c2805ad78806254564ac9a6bb680d180b.zip
resolves bug 7794 for gcc3.2 compat
Diffstat (limited to 'app-text/htmlinc')
-rw-r--r--app-text/htmlinc/ChangeLog12
-rw-r--r--app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch81
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1.ebuild14
3 files changed, 101 insertions, 6 deletions
diff --git a/app-text/htmlinc/ChangeLog b/app-text/htmlinc/ChangeLog
index b6ffa04f16cb..faca0ee8c066 100644
--- a/app-text/htmlinc/ChangeLog
+++ b/app-text/htmlinc/ChangeLog
@@ -1,11 +1,19 @@
# ChangeLog for app-text/htmlinc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/ChangeLog,v 1.2 2002/08/02 17:42:49 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/ChangeLog,v 1.3 2002/09/16 09:43:47 mkennedy Exp $
*htmlinc-1.0_beta1 (22 Jun 2002)
+ 16 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ htmlinc-1.0_beta1.ebuild, files/digest-htmlinc-1.0_beta1, ChangeLog,
+ files/htmlinc-gcc3-gentoo.patch :
+
+ Resolves bug 7794 for gcc3.2. Thanks to <hanno@gentoo.org>
+
2 Aug 2002; phoen][x <phoenix@gentoo.org> htmlinc-1.0_beta1.ebuild :
+
Added KEYWORDS, SLOT.
+
22 Jun 2002; Nicholas Jones <carpaski@gentoo.org> :
- o Initial submission for Hanno Boeck <hanno@gmx.de> \ No newline at end of file
+ Initial submission for Hanno Boeck <hanno@gmx.de> \ No newline at end of file
diff --git a/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
new file mode 100644
index 000000000000..63a783dfa6e0
--- /dev/null
+++ b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
@@ -0,0 +1,81 @@
+diff -u htmlinc/bytevector.cc htmlinc-1/bytevector.cc
+--- htmlinc/bytevector.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.cc 2002-09-11 13:55:25.000000000 +0200
+@@ -119,7 +119,7 @@
+ }
+
+ bool Bytevector::freadln(int file,char seperator){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+@@ -152,7 +152,7 @@
+
+
+ void Bytevector::freadeof(int file){
+- vector<Bytevector*> v;
++ std::vector<Bytevector*> v;
+ Bytevector *b;
+ int index=0;
+ int status;
+diff -u htmlinc/bytevector.h htmlinc-1/bytevector.h
+--- htmlinc/bytevector.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/bytevector.h 2002-09-11 13:54:50.000000000 +0200
+@@ -54,7 +54,7 @@
+
+
+
+-class VectorIndexList : public vector<int> {
++class VectorIndexList : public std::vector<int> {
+ };
+
+
+diff -u htmlinc/stringlist.cc htmlinc-1/stringlist.cc
+--- htmlinc/stringlist.cc 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.cc 2002-09-11 13:57:47.000000000 +0200
+@@ -283,7 +283,7 @@
+ for (Stringlist::iterator i=begin(); i!=end(); i++){
+ delete *i;
+ }
+- vector<Bytevector *>::clear();
++ std::vector<Bytevector *>::clear();
+ }
+
+
+@@ -373,7 +373,7 @@
+
+ void Stringlist::insert(Bytevector *b, int pos){
+ iterator i=begin()+pos;
+- vector<Bytevector *>::insert(i,b);
++ std::vector<Bytevector *>::insert(i,b);
+ }
+
+ void Stringlist::insert(Bytevector &b, int pos){
+@@ -417,7 +417,7 @@
+
+
+ Bytevector& Stringlist::operator[](int i){
+- return *(vector<Bytevector *>::operator[](i));
++ return *(std::vector<Bytevector *>::operator[](i));
+ }
+
+
+diff -u htmlinc/stringlist.h htmlinc-1/stringlist.h
+--- htmlinc/stringlist.h 2000-08-07 10:56:23.000000000 +0200
++++ htmlinc-1/stringlist.h 2002-09-11 13:56:32.000000000 +0200
+@@ -57,12 +57,12 @@
+ }
+ };
+
+-class MatrixIndexList: public vector<MatrixIndex> {
++class MatrixIndexList: public std::vector<MatrixIndex> {
+ };
+
+
+
+-class Stringlist : public vector<Bytevector*> {
++class Stringlist : public std::vector<Bytevector*> {
+ private:
+ Stringlist::iterator getID(Bytevector id);
+
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
index b28e81f95c1a..98b53835cb2b 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
@@ -1,16 +1,22 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.3 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.4 2002/09/16 09:43:47 mkennedy Exp $
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
KEYWORDS="x86 sparc sparc64"
SLOT="0"
-LICENSE="GPL"
-DEPEND=""
-SRC_URI="http://meybohm.de/files/htmlinc.tar.gz"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+RDEPEND=${DEPEND}
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
S=${WORKDIR}/htmlinc
+src_unpack() {
+ unpack ${PN}.tar.gz
+ patch -p0 < ${FILESDIR}/htmlinc-gcc3-gentoo.patch
+}
+
src_compile() {
emake CFLAGS="${CXXFLAGS} -Wall" || die
}