summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-03-25 22:13:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-03-25 22:13:52 +0000
commit9e413e3eeb34d1159d99985b8e235e4595356bb0 (patch)
tree1359ae4af0102102131fada28a32716d08e839b7 /app-text/glark
parentStable on x86, bug #172025. (diff)
downloadgentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.tar.gz
gentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.tar.bz2
gentoo-2-9e413e3eeb34d1159d99985b8e235e4595356bb0.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/glark')
-rw-r--r--app-text/glark/ChangeLog8
-rw-r--r--app-text/glark/files/1.8.0/glark-completion33
-rw-r--r--app-text/glark/files/digest-glark-1.8.03
-rw-r--r--app-text/glark/glark-1.8.0.ebuild31
4 files changed, 74 insertions, 1 deletions
diff --git a/app-text/glark/ChangeLog b/app-text/glark/ChangeLog
index f63e65ab8fda..4703369111db 100644
--- a/app-text/glark/ChangeLog
+++ b/app-text/glark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/glark
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.42 2007/03/25 21:59:06 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/ChangeLog,v 1.43 2007/03/25 22:13:52 dirtyepic Exp $
+
+*glark-1.8.0 (25 Mar 2007)
+
+ 25 Mar 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/1.8.0/glark-completion, +glark-1.8.0.ebuild:
+ Version bump.
25 Mar 2007; Andrej Kacian <ticho@gentoo.org> glark-1.7.8.ebuild:
Stable on x86, bug #156802.
diff --git a/app-text/glark/files/1.8.0/glark-completion b/app-text/glark/files/1.8.0/glark-completion
new file mode 100644
index 000000000000..be1706f63686
--- /dev/null
+++ b/app-text/glark/files/1.8.0/glark-completion
@@ -0,0 +1,33 @@
+# Author: Ciaran McCreesh <ciaranm@gentoo.org>
+#
+# completion for glark
+
+_glark()
+{
+ local cur prev
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ if [[ "${cur}" == -* ]] || [[ ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $( compgen -W ' --directories --binary-files --basename \
+ --name --fullname --path --exclude-matching --recurse --size-limit \
+ --split-as-path --no-split-as-path --and --before --after \
+ --file --ignore-case --match-limit --or --range \
+ --invert-match --word --word-regexp --line-regexp --xor \
+ --after-context --before-context --context --count \
+ --file-color --no-filter --grep --no-filename --with-filename \
+ --files-with-matches --files-without-match --line-number \
+ --no-line-number --line-number-color --text-color --highlight \
+ --no-highlight --extract-matches --null --help --conf --dump \
+ --explain --quiet --no-messages --no-quiet --version \
+ --verbose --label' -- $cur ) )
+ else
+ _filedir
+ fi
+}
+
+complete -o filenames -F _glark glark
+
+# vim: set ft=sh sw=4 et sts=4 :
diff --git a/app-text/glark/files/digest-glark-1.8.0 b/app-text/glark/files/digest-glark-1.8.0
new file mode 100644
index 000000000000..0e3b0f7158a5
--- /dev/null
+++ b/app-text/glark/files/digest-glark-1.8.0
@@ -0,0 +1,3 @@
+MD5 30ef4c3383eddbc1ae8ff927f02d5fb3 glark-1.8.0.tar.gz 40599
+RMD160 58c7beb3f0eeb5ac7b70320702256f91260394f0 glark-1.8.0.tar.gz 40599
+SHA256 e35e39c0740d862995d82d97e15458de6999c408cfe02fb5922467436970dd4e glark-1.8.0.tar.gz 40599
diff --git a/app-text/glark/glark-1.8.0.ebuild b/app-text/glark/glark-1.8.0.ebuild
new file mode 100644
index 000000000000..1706a6cb076c
--- /dev/null
+++ b/app-text/glark/glark-1.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.8.0.ebuild,v 1.1 2007/03/25 22:13:52 dirtyepic Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://www.incava.org/projects/glark/"
+SRC_URI="http://www.incava.org/pub/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dobashcompletion "${FILESDIR}"/1.8.0/glark-completion ${PN}
+}