summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-06-25 04:12:43 +0000
committerMike Gilbert <floppym@gentoo.org>2014-06-25 04:12:43 +0000
commitedecb6a5aa0c81241ff44051c963baa79fde1e43 (patch)
treedbeb52423bd16f67bcfecf1487beaa877ea99d86 /app-shells/ksh
parentAdd python3_4 to PYTHON_COMPAT (diff)
downloadgentoo-2-edecb6a5aa0c81241ff44051c963baa79fde1e43.tar.gz
gentoo-2-edecb6a5aa0c81241ff44051c963baa79fde1e43.tar.bz2
gentoo-2-edecb6a5aa0c81241ff44051c963baa79fde1e43.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/ChangeLog9
-rw-r--r--app-shells/ksh/ksh-93.20140606.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 6177482c2e94..785213bb6664 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.63 2013/03/17 15:36:08 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.64 2014/06/25 04:12:43 floppym Exp $
+
+*ksh-93.20140606 (25 Jun 2014)
+
+ 25 Jun 2014; Mike Gilbert <floppym@gentoo.org> +ksh-93.20140606.ebuild:
+ Version bump.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/app-shells/ksh/ksh-93.20140606.ebuild b/app-shells/ksh/ksh-93.20140606.ebuild
new file mode 100644
index 000000000000..1d5263cc209b
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20140606.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20140606.ebuild,v 1.1 2014/06/25 04:12:43 floppym Exp $
+
+EAPI=5
+
+inherit toolchain-funcs prefix eutils
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+
+KSH_PV=${PV:3:4}-${PV:7:2}-${PV:9:2}
+
+SRC_URI="http://dev.gentoo.org/~floppym/distfiles/INIT.${KSH_PV}.tgz
+ http://dev.gentoo.org/~floppym/distfiles/ast-base.${KSH_PV}.tgz"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!app-shells/pdksh"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Bug 238906.
+ sed -i -e 's,cd /tmp,cd "${TMPDIR:-/tmp}",' \
+ bin/package src/cmd/INIT/package.sh || die
+
+ epatch "${FILESDIR}"/${PN}-prefix.patch
+ eprefixify src/cmd/ksh93/data/msg.c
+}
+
+src_compile() {
+ tc-export AR CC LD NM
+ export CCFLAGS="${CFLAGS}"
+ sh bin/package make ast-ksh SHELL=sh SHOPT_SYSRC=1 || die
+}
+
+src_install() {
+ dodoc lib/package/ast-base.README
+ dohtml lib/package/ast-base.html
+
+ local myhost=$(sh bin/package host)
+ cd "arch/${myhost}" || die
+ into /
+ dobin bin/ksh
+ dosym ksh /bin/rksh
+ newman man/man1/sh.1 ksh.1
+}