summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-12-25 16:10:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-12-25 16:10:09 +0000
commitdfc9e3c7b76b5400b60117a7eb2fb43aad15552d (patch)
treee38ae880aadc65235c9473ff698aebc86c5fab10 /app-portage
parentFixes bugs 395263, 394389, and 394159 (diff)
downloadgentoo-2-dfc9e3c7b76b5400b60117a7eb2fb43aad15552d.tar.gz
gentoo-2-dfc9e3c7b76b5400b60117a7eb2fb43aad15552d.tar.bz2
gentoo-2-dfc9e3c7b76b5400b60117a7eb2fb43aad15552d.zip
version bump, minor bug fixes/improvements
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.23.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 50b6ba9c8b4e..93b1a25a3b17 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.390 2011/12/17 19:22:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.391 2011/12/25 16:10:09 darkside Exp $
+
+*eix-0.23.4 (25 Dec 2011)
+
+ 25 Dec 2011; Jeremy Olexa <darkside@gentoo.org> +eix-0.23.4.ebuild:
+ version bump, minor bug fixes/improvements
17 Dec 2011; Raúl Porcel <armin76@gentoo.org> eix-0.23.3-r1.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #393435
diff --git a/app-portage/eix/eix-0.23.4.ebuild b/app-portage/eix/eix-0.23.4.ebuild
new file mode 100644
index 000000000000..3827d77da664
--- /dev/null
+++ b/app-portage/eix/eix-0.23.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.23.4.ebuild,v 1.1 2011/12/25 16:10:09 darkside Exp $
+
+EAPI=4
+
+inherit multilib bash-completion-r1
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ --without-bzip2 \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+}