summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-04 15:34:39 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-04 15:34:39 +0000
commit54caff4cb99d0f8931f2c967a9250f261fabb139 (patch)
treed1d4575f62b28a7672499890355d11fa384684b2 /app-office/texstudio
parentsci-libs/punc: Bump EAPI (diff)
downloadgentoo-2-54caff4cb99d0f8931f2c967a9250f261fabb139.tar.gz
gentoo-2-54caff4cb99d0f8931f2c967a9250f261fabb139.tar.bz2
gentoo-2-54caff4cb99d0f8931f2c967a9250f261fabb139.zip
app-office/texstudio: Add stable version back, #533826
(Portage version: 2.2.15/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office/texstudio')
-rw-r--r--app-office/texstudio/ChangeLog7
-rw-r--r--app-office/texstudio/texstudio-2.8.4.ebuild84
2 files changed, 89 insertions, 2 deletions
diff --git a/app-office/texstudio/ChangeLog b/app-office/texstudio/ChangeLog
index 7baf08b499b9..8e2466953a06 100644
--- a/app-office/texstudio/ChangeLog
+++ b/app-office/texstudio/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/texstudio
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.34 2014/12/31 12:49:16 kensington Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.35 2015/01/04 15:34:39 jlec Exp $
+
+ 04 Jan 2015; Justin Lecher <jlec@gentoo.org> +texstudio-2.8.4.ebuild:
+ Add stable version back, #533826
31 Dec 2014; Michael Palimaka <kensington@gentoo.org> texstudio-2.8.6.ebuild,
texstudio-2.8.8.ebuild:
diff --git a/app-office/texstudio/texstudio-2.8.4.ebuild b/app-office/texstudio/texstudio-2.8.4.ebuild
new file mode 100644
index 000000000000..241f9a62b785
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.8.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.8.4.ebuild,v 1.5 2015/01/04 15:34:39 jlec Exp $
+
+EAPI=5
+
+inherit base fdo-mime prefix qt4-r2
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ dev-libs/quazip
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/designer:4
+ >=dev-qt/qtgui-4.8.5:4
+ >=dev-qt/qtcore-4.6.1:4
+ >=dev-qt/qtscript-4.6.1:4
+ dev-qt/qtsingleapplication
+ >=dev-qt/qtsvg-4.6.1:4
+ >=dev-qt/qttest-4.6.1:4
+ video? ( media-libs/phonon )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.4-hunspell-quazip.patch
+ "${FILESDIR}"/${PN}-2.8.2-desktop.patch
+# Get it from fedora
+ "${FILESDIR}"/${PN}-2.5-viewers-use-xdg-open.patch
+ )
+
+src_prepare() {
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/hunspell.pri/d' \
+ -e '/quazip.pri/d' \
+ -e '/qtsingleapplication.pri/d' \
+ -e '/QUAZIP_STATIC/d' \
+ -i ${PN}.pro || die
+
+# cat >> ${PN}.pro <<- EOF
+# exists(texmakerx_my.pri):include(texmakerx_my.pri)
+# EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ insinto /usr/share/icons/hicolor/${i}
+ newins utilities/${PN}${i}.png ${PN}.png
+ done
+ qt4-r2_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}