summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-08-01 17:55:19 +0000
committerDan Armak <danarmak@gentoo.org>2001-08-01 17:55:19 +0000
commit89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8 (patch)
tree33594fd138745287e70efbfd15da171de28fcf7c /app-office/lyx-base
parentnoweb: a literate programming tool, lighter than web (diff)
downloadgentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.tar.gz
gentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.tar.bz2
gentoo-2-89b8fc2c5b9222606c6cde1bac88dd54fb9c16f8.zip
lyx 1.1.6fix3, replaces fix2. Note that lthe new lyx-utils includes many new deps, some of them just now aded to portage. hey aren't completely tested and that's why I'm keeping 1.1.6fix2 yet. lyx-base updates are always stable.
Diffstat (limited to 'app-office/lyx-base')
-rw-r--r--app-office/lyx-base/files/digest-lyx-base-1.1.6.31
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.2.ebuild2
-rw-r--r--app-office/lyx-base/lyx-base-1.1.6.3.ebuild46
3 files changed, 48 insertions, 1 deletions
diff --git a/app-office/lyx-base/files/digest-lyx-base-1.1.6.3 b/app-office/lyx-base/files/digest-lyx-base-1.1.6.3
new file mode 100644
index 000000000000..15faa84195c3
--- /dev/null
+++ b/app-office/lyx-base/files/digest-lyx-base-1.1.6.3
@@ -0,0 +1 @@
+MD5 b97a87d87d5c19da917547d9b81fab89 lyx-1.1.6fix3.tar.gz
diff --git a/app-office/lyx-base/lyx-base-1.1.6.2.ebuild b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
index fa6bf3963e9d..6b6625b9e4f4 100644
--- a/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
+++ b/app-office/lyx-base/lyx-base-1.1.6.2.ebuild
@@ -13,7 +13,7 @@ DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
of forcing you to learn LaTeX markup syntax and use the\
proper tags, however, it is a WYSIWYM program."
-SRC_URI="ftp://ftp.lyx.org/pub/${A}"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${A}"
HOMEPAGE="http://www.lyx.org/"
diff --git a/app-office/lyx-base/lyx-base-1.1.6.3.ebuild b/app-office/lyx-base/lyx-base-1.1.6.3.ebuild
new file mode 100644
index 000000000000..832f1a914d90
--- /dev/null
+++ b/app-office/lyx-base/lyx-base-1.1.6.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $ /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp$
+
+# The real version of LyX is 1.1.6fix3. As Portage has no support for
+# arbitrary suffixes like 'fix' (yet), this is translated into 1.1.6.3.
+P=lyx-1.1.6fix3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+
+DESCRIPTION="LyX is an Xwindows graphical frontend for LaTeX. Instead\
+ of forcing you to learn LaTeX markup syntax and use the\
+ proper tags, however, it is a WYSIWYM program."
+
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${A}"
+
+HOMEPAGE="http://www.lyx.org/"
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-devel/ld.so"
+
+src_compile() {
+
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ try emake
+
+}
+
+src_install () {
+
+ # install-strip is a special target provided by the LyX makefile
+ # for striping installed binaries.
+ try make DESTDIR=${D} install-strip
+
+}
+