summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 20:03:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 20:03:43 +0000
commitbd535a24ca318b8085ff88dfa47510843c3fbc2b (patch)
tree8cd2b547bfcd58a4fc4086954fa2dbfd8dc1f8a9 /app-mobilephone
parentFix dependencies. Set SUPPORT_PYTHON_ABIS (bug #311539). (diff)
downloadgentoo-2-bd535a24ca318b8085ff88dfa47510843c3fbc2b.tar.gz
gentoo-2-bd535a24ca318b8085ff88dfa47510843c3fbc2b.tar.bz2
gentoo-2-bd535a24ca318b8085ff88dfa47510843c3fbc2b.zip
Fix deprecation warnings.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog8
-rw-r--r--app-mobilephone/gammu/gammu-1.25.0-r1.ebuild16
-rw-r--r--app-mobilephone/gammu/gammu-1.28.0.ebuild21
3 files changed, 34 insertions, 11 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 384b63f9962a..c9f1d2721d96 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/gammu
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.85 2010/12/29 21:01:24 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.86 2011/01/08 20:03:43 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gammu-1.25.0-r1.ebuild, gammu-1.28.0.ebuild:
+ Fix deprecation warnings.
29 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
-gammu-1.26.1-r1.ebuild, -gammu-1.27.0.ebuild:
diff --git a/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild
index 111ff7a1cae1..409a32e2829a 100644
--- a/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild
+++ b/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild,v 1.6 2010/06/17 21:26:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.25.0-r1.ebuild,v 1.7 2011/01/08 20:03:43 arfrever Exp $
-EAPI="2"
+EAPI="3"
-inherit eutils cmake-utils distutils
+inherit eutils cmake-utils python
DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
HOMEPAGE="http://www.gammu.org"
@@ -83,3 +83,11 @@ src_test() {
src_install() {
cmake-utils_src_install
}
+
+pkg_postinst() {
+ use python && python_mod_optimize gammu
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup gammu
+}
diff --git a/app-mobilephone/gammu/gammu-1.28.0.ebuild b/app-mobilephone/gammu/gammu-1.28.0.ebuild
index 4812f35d8b8f..317991612bf3 100644
--- a/app-mobilephone/gammu/gammu-1.28.0.ebuild
+++ b/app-mobilephone/gammu/gammu-1.28.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.28.0.ebuild,v 1.1 2010/10/09 19:29:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.28.0.ebuild,v 1.2 2011/01/08 20:03:43 arfrever Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit eutils cmake-utils distutils
+inherit eutils cmake-utils python
DESCRIPTION="A tool to handle your cellular phone"
HOMEPAGE="http://www.wammu.eu/"
@@ -37,7 +37,10 @@ MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
pkg_setup() {
- python_set_active_version 2
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -90,3 +93,11 @@ src_test() {
src_install() {
cmake-utils_src_install
}
+
+pkg_postinst() {
+ use python && python_mod_optimize gammu
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup gammu
+}