summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-11-10 10:15:16 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-11-10 10:15:16 +0000
commiteb8c1485d03765053de64a7fe67ee60344a9407d (patch)
treecc0477e537d9a79ff649789184f928bbf6d6a0c2 /app-misc/celestia
parentrearrange the FILESDIR so that every version has a subdir of its own, since m... (diff)
downloadgentoo-2-eb8c1485d03765053de64a7fe67ee60344a9407d.tar.gz
gentoo-2-eb8c1485d03765053de64a7fe67ee60344a9407d.tar.bz2
gentoo-2-eb8c1485d03765053de64a7fe67ee60344a9407d.zip
fix to filter -funroll-loops out
Diffstat (limited to 'app-misc/celestia')
-rw-r--r--app-misc/celestia/ChangeLog8
-rw-r--r--app-misc/celestia/celestia-1.2.4.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/app-misc/celestia/ChangeLog b/app-misc/celestia/ChangeLog
index bf38686d5f79..420a1123658a 100644
--- a/app-misc/celestia/ChangeLog
+++ b/app-misc/celestia/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for app-misc/celestia
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/ChangeLog,v 1.4 2002/10/24 05:07:41 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/ChangeLog,v 1.5 2002/11/10 10:15:16 george Exp $
*celestia-1.2.4 (4 May 2002)
- 23 Oct 2002; George Shapovalov <george@gentoo.org> celestia-1.2.4.ebuildi, files/celestia-gcc3.patch :
+ 09 Nov 2002; George Shapovalov <george@gentoo.org> celestia-1.2.4.ebuild :
+
+ another fix - to filter out -funroll-loops which causes trouble with gcc-3.2
+
+ 23 Oct 2002; George Shapovalov <george@gentoo.org> celestia-1.2.4.ebuild, files/celestia-gcc3.patch :
applied fix to make celestia compile under gcc-3.x,
Thanks to Bret Towe <btowe@gbis.com>, bug #6417
diff --git a/app-misc/celestia/celestia-1.2.4.ebuild b/app-misc/celestia/celestia-1.2.4.ebuild
index 8c895e927cb2..bf2ee085fc84 100644
--- a/app-misc/celestia/celestia-1.2.4.ebuild
+++ b/app-misc/celestia/celestia-1.2.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/celestia-1.2.4.ebuild,v 1.10 2002/10/24 05:07:41 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/celestia/celestia-1.2.4.ebuild,v 1.11 2002/11/10 10:15:16 george Exp $
+
+inherit flag-o-matic
IUSE="gtk gnome"
@@ -31,6 +33,8 @@ src_unpack() {
src_compile() {
local myconf
+ filter-flags "-funroll-loops -frerun-loop-opt"
+
# currently celestia's "gtk support" requires gnome
use gtk || myconf="--without-gtk"
use gnome || myconf="--without-gtk"