summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-06-14 05:05:37 +0000
committerNaohiro Aota <naota@gentoo.org>2012-06-14 05:05:37 +0000
commit08cf467124e459c37f35588a7b1795f2896ca524 (patch)
tree3282ba2258db8ade7fafc4c40e0e4502bed742be /app-i18n
parentPut gpg dep behind a USE flag as this signing requirement only really matters... (diff)
downloadgentoo-2-08cf467124e459c37f35588a7b1795f2896ca524.tar.gz
gentoo-2-08cf467124e459c37f35588a7b1795f2896ca524.tar.bz2
gentoo-2-08cf467124e459c37f35588a7b1795f2896ca524.zip
Version bump. Add patch to detect cdb header properly.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/multiskkserv/ChangeLog10
-rw-r--r--app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch45
-rw-r--r--app-i18n/multiskkserv/multiskkserv-20100128.ebuild48
3 files changed, 101 insertions, 2 deletions
diff --git a/app-i18n/multiskkserv/ChangeLog b/app-i18n/multiskkserv/ChangeLog
index 1c5e41adfb92..fd66e652f093 100644
--- a/app-i18n/multiskkserv/ChangeLog
+++ b/app-i18n/multiskkserv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/multiskkserv
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/multiskkserv/ChangeLog,v 1.14 2011/04/13 15:17:32 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/multiskkserv/ChangeLog,v 1.15 2012/06/14 05:05:37 naota Exp $
+
+*multiskkserv-20100128 (14 Jun 2012)
+
+ 14 Jun 2012; Naohiro Aota <naota@gentoo.org>
+ +files/multiskkserv-20100128-cdb.patch, +multiskkserv-20100128.ebuild:
+ Version bump. Add patch to detect cdb header properly.
13 Apr 2011; Ulrich Mueller <ulm@gentoo.org> multiskkserv-20020201.ebuild,
multiskkserv-20051220.ebuild:
diff --git a/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch b/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch
new file mode 100644
index 000000000000..938043ca46b3
--- /dev/null
+++ b/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch
@@ -0,0 +1,45 @@
+diff --git a/configure.in b/configure.in
+index 648f742..2ac4e92 100644
+--- a/configure.in
++++ b/configure.in
+@@ -108,22 +108,24 @@ if test "$with_cdb" = "no"; then
+ else
+ if test "$with_cdb" = "yes"; then
+ for i in /usr/local /usr; do
+- if test -d "$i/include" -a -f "$i/include/cdb.h"; then
+- CDB_DIR="$i"
+- CDB_INCLUDES="-I$i/include"
+- available_cdb="yes"
+- for j in cdb.a buffer.a unix.a byte.a alloc.a; do
+- if test -f "$i/lib/$j"; then
+- LIBADD_CDB="$LIBADD_CDB $i/lib/$j"
+- else
+- available_cdb="no"
+- break
+- fi
+- done
+- if test "$available_cdb" = "yes"; then
+- break
+- fi
+- fi
++ for inc in include include/cdb; do
++ if test -d "$i/$inc" -a -f "$i/$inc/cdb.h"; then
++ CDB_DIR="$i"
++ CDB_INCLUDES="-I$i/$inc"
++ available_cdb="yes"
++ for j in cdb.a buffer.a unix.a byte.a alloc.a; do
++ if test -f "$i/lib/$j"; then
++ LIBADD_CDB="$LIBADD_CDB $i/lib/$j"
++ else
++ available_cdb="no"
++ break
++ fi
++ done
++ if test "$available_cdb" = "yes"; then
++ break
++ fi
++ fi
++ done
+ done
+ else
+ if test -d "$with_cdb" -a -f "$with_cdb/cdb.h"; then
diff --git a/app-i18n/multiskkserv/multiskkserv-20100128.ebuild b/app-i18n/multiskkserv/multiskkserv-20100128.ebuild
new file mode 100644
index 000000000000..52368a500e3a
--- /dev/null
+++ b/app-i18n/multiskkserv/multiskkserv-20100128.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/multiskkserv/multiskkserv-20100128.ebuild,v 1.1 2012/06/14 05:05:37 naota Exp $
+
+EAPI="3"
+
+inherit eutils fixheadtails autotools
+
+DESCRIPTION="SKK server that handles multiple dictionaries"
+HOMEPAGE="http://www3.big.or.jp/~sian/linux/products/"
+SRC_URI="http://www3.big.or.jp/~sian/linux/products/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ dev-db/cdb"
+RDEPEND="|| (
+ >=app-i18n/skk-jisyo-200705[cdb]
+ app-i18n/skk-jisyo-cdb
+ )"
+
+src_prepare() {
+ ht_fix_all
+ epatch "${FILESDIR}"/${P}-cdb.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-cdb=yes || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ newconfd "${FILESDIR}"/multiskkserv.conf multiskkserv || die
+ newinitd "${FILESDIR}"/multiskkserv.initd multiskkserv || die
+
+ dodoc AUTHORS ChangeLog NEWS README* || die
+}
+
+pkg_postinst() {
+ elog "By default, multiskkserv will look up only SKK-JISYO.L.cdb."
+ elog "If you want to use more dictionaries,"
+ elog "edit /etc/conf.d/multiskkserv manually."
+}