summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-21 22:19:09 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-21 22:19:09 +0000
commitbe55744c23b42608f07a06127482c7fd29c73515 (patch)
treece8f1635b89ba5bd97f7479ec7bba55ee84c54b5 /app-emulation
parentTentative fix for Bug 430894, net-snmp compatibility with apcupsd. (diff)
downloadgentoo-2-be55744c23b42608f07a06127482c7fd29c73515.tar.gz
gentoo-2-be55744c23b42608f07a06127482c7fd29c73515.tar.bz2
gentoo-2-be55744c23b42608f07a06127482c7fd29c73515.zip
Add patch to fix vmhgfs in linux-3.11, bug 488648.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools-kmod/ChangeLog6
-rw-r--r--app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch42
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild7
3 files changed, 50 insertions, 5 deletions
diff --git a/app-emulation/open-vm-tools-kmod/ChangeLog b/app-emulation/open-vm-tools-kmod/ChangeLog
index 152f5ec48054..cb23ed663c8c 100644
--- a/app-emulation/open-vm-tools-kmod/ChangeLog
+++ b/app-emulation/open-vm-tools-kmod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/open-vm-tools-kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.40 2013/10/19 23:14:03 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.41 2013/10/21 22:19:08 floppym Exp $
+
+ 21 Oct 2013; Mike Gilbert <floppym@gentoo.org> +files/vmhgfs-linux-3.11.patch,
+ open-vm-tools-kmod-2013.09.16.1328054.ebuild:
+ Add patch to fix vmhgfs in linux-3.11, bug 488648.
*open-vm-tools-kmod-9.4.0.1280544 (19 Oct 2013)
diff --git a/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch b/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch
new file mode 100644
index 000000000000..3918162a7057
--- /dev/null
+++ b/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch
@@ -0,0 +1,42 @@
+Source: https://github.com/rasa/vmware-tools-patches/
+
+--- a/modules/linux/vmhgfs/inode.c
++++ b/modules/linux/vmhgfs/inode.c
+@@ -31,6 +31,9 @@
+ #include <linux/namei.h>
+ #endif
+ #include <linux/highmem.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++#include <linux/dcache.h>
++#endif
+
+ #include "compat_cred.h"
+ #include "compat_fs.h"
+@@ -1890,7 +1893,11 @@
+ #endif
+ &inode->i_dentry,
+ d_alias) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++ int dcount = d_count(dentry);
++#else
+ int dcount = dentry->d_count;
++#endif
+ if (dcount) {
+ LOG(4, ("Found %s %d \n", dentry->d_name.name, dcount));
+ return HgfsAccessInt(dentry, mask & (MAY_READ | MAY_WRITE | MAY_EXEC));
+@@ -1943,10 +1950,12 @@
+ list_for_each(pos, &inode->i_dentry) {
+ int dcount;
+ struct dentry *dentry = list_entry(pos, struct dentry, d_alias);
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 38)
+- dcount = atomic_read(&dentry->d_count);
+-#else
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++ dcount = d_count(dentry);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
+ dcount = dentry->d_count;
++#else
++ dcount = atomic_read(&dentry->d_count);
+ #endif
+ if (dcount) {
+ LOG(4, ("Found %s %d \n", (dentry)->d_name.name, dcount));
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild
index 326561a30a99..dffb3bbc4507 100644
--- a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild
+++ b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild,v 1.3 2013/10/19 17:02:24 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild,v 1.4 2013/10/21 22:19:08 floppym Exp $
EAPI="5"
@@ -30,7 +30,7 @@ pkg_setup() {
if kernel_is -lt 3 9; then
MODULES+=" vmci vsock"
else
- CONFIG_CHECK+=" ~VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS"
+ CONFIG_CHECK+=" VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS"
fi
if kernel_is -lt 3; then
@@ -48,8 +48,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/frozen.patch"
- epatch "${FILESDIR}/putname.patch"
+ epatch "${FILESDIR}/vmhgfs-linux-3.11.patch"
epatch_user
}