summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-08-17 18:01:35 +0000
committerLance Albertson <ramereth@gentoo.org>2010-08-17 18:01:35 +0000
commita200142f6d4e5252c2aa7bb93334c5de94cd5476 (patch)
tree7eb5e30a9388da6e7897fcee7b620187f7e88b5f /app-emulation
parentStable on amd64 wrt bug #331623 (diff)
downloadgentoo-2-a200142f6d4e5252c2aa7bb93334c5de94cd5476.tar.gz
gentoo-2-a200142f6d4e5252c2aa7bb93334c5de94cd5476.tar.bz2
gentoo-2-a200142f6d4e5252c2aa7bb93334c5de94cd5476.zip
Version bump, install api docs optionally
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog8
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.2.6.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
index 744d1cc7bc95..56b787f99ceb 100644
--- a/app-emulation/ganeti-htools/ChangeLog
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-htools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.2 2010/05/07 21:16:08 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.3 2010/08/17 18:01:35 ramereth Exp $
+
+*ganeti-htools-0.2.6 (17 Aug 2010)
+
+ 17 Aug 2010; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-htools-0.2.6.ebuild:
+ Version bump, install api docs optionally
*ganeti-htools-0.2.5 (07 May 2010)
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.2.6.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.2.6.ebuild
new file mode 100644
index 000000000000..d4453394f86a
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.2.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.2.6.ebuild,v 1.1 2010/08/17 18:01:35 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman *.1
+ dodoc README NEWS AUTHORS
+ use doc && dohtml -r apidoc/*
+}