summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-08-11 16:22:04 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-08-11 16:22:04 +0000
commit215f114e62595df98a4956ba5a29441731b906e8 (patch)
tree09f26354586703cd5ed1f697bce8623d44498295 /app-emulation
parentAdded slotted version 0.5.1 needed for app-emulation/spice. Added a version b... (diff)
downloadgentoo-2-215f114e62595df98a4956ba5a29441731b906e8.tar.gz
gentoo-2-215f114e62595df98a4956ba5a29441731b906e8.tar.bz2
gentoo-2-215f114e62595df98a4956ba5a29441731b906e8.zip
Initial commit, ebuild written by me.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog10
-rw-r--r--app-emulation/spice/metadata.xml12
-rw-r--r--app-emulation/spice/spice-0.5.3.ebuild44
3 files changed, 66 insertions, 0 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
new file mode 100644
index 000000000000..06f3d4cc7562
--- /dev/null
+++ b/app-emulation/spice/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/spice
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.1 2010/08/11 16:22:04 dev-zero Exp $
+
+*spice-0.5.3 (11 Aug 2010)
+
+ 11 Aug 2010; Tiziano Müller <dev-zero@gentoo.org> +spice-0.5.3.ebuild,
+ +metadata.xml:
+ Initial commit, ebuild written by me.
+
diff --git a/app-emulation/spice/metadata.xml b/app-emulation/spice/metadata.xml
new file mode 100644
index 000000000000..802f892562a9
--- /dev/null
+++ b/app-emulation/spice/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <use>
+ <flag name="gui">Build some GUI components (inside the guest window).</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/spice/spice-0.5.3.ebuild b/app-emulation/spice/spice-0.5.3.ebuild
new file mode 100644
index 000000000000..c697c5084785
--- /dev/null
+++ b/app-emulation/spice/spice-0.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.5.3.ebuild,v 1.1 2010/08/11 16:22:04 dev-zero Exp $
+
+EAPI=3
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui opengl static-libs"
+
+RDEPEND="~app-emulation/spice-protocol-${PV}
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ media-libs/jpeg
+ sys-libs/zlib
+ gui? ( dev-games/cegui[opengl?] )
+ opengl? ( virtual/opengl )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_configure() {
+ local myconf=""
+ use gui && myconf+="--enable-gui "
+ use opengl && myconf+="--enable-opengl "
+ econf ${myconf} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}