summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-05-27 06:41:30 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-05-27 06:41:30 +0000
commitd164bed059e1fcda6f1078f29a0883440b79b5a1 (patch)
treec4fdacfed0ce0b2193022810e70bc7af84e0668a /app-emulation/pcsx/pcsx-1.4.ebuild
parentAdded ~mips to KEYWORDS (diff)
downloadgentoo-2-d164bed059e1fcda6f1078f29a0883440b79b5a1.tar.gz
gentoo-2-d164bed059e1fcda6f1078f29a0883440b79b5a1.tar.bz2
gentoo-2-d164bed059e1fcda6f1078f29a0883440b79b5a1.zip
new version 1.5 - someone please fix up RDEPEND if it's broken
Diffstat (limited to 'app-emulation/pcsx/pcsx-1.4.ebuild')
-rw-r--r--app-emulation/pcsx/pcsx-1.4.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/app-emulation/pcsx/pcsx-1.4.ebuild b/app-emulation/pcsx/pcsx-1.4.ebuild
index 1efce30842ab..b5c82373ea51 100644
--- a/app-emulation/pcsx/pcsx-1.4.ebuild
+++ b/app-emulation/pcsx/pcsx-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/pcsx-1.4.ebuild,v 1.4 2003/02/13 07:15:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/pcsx-1.4.ebuild,v 1.5 2003/05/27 06:41:26 msterret Exp $
S=${WORKDIR}
DESCRIPTION="Playstation emulator"
@@ -16,34 +16,33 @@ use opengl && GLDEPEND="app-emulation/psemu-gpupetemesagl"
use opengl || GLDEPEND="app-emulation/psemu-peopssoftgpu"
DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
app-arch/unzip
x11-libs/gtk+
gnome-base/libglade"
-#RDEPEND="net-misc/wget
-# app-emulation/psemu-cdr
-# app-emulation/psemu-cdriso
-# app-emulation/psemu-padxwin
-# app-emulation/psemu-padjoy
-# app-emulation/psemu-peopsspu
-# ${GLDEPEND}"
+RDEPEND="app-emulation/psemu-cdr
+ app-emulation/psemu-cdriso
+ app-emulation/psemu-padxwin
+ app-emulation/psemu-padjoy
+ app-emulation/psemu-peopsspu
+ ${GLDEPEND}"
src_compile() {
cd PcsxSrc/Linux
# Change some defaults...
- sed -e 's:Plugin/:/usr/lib/psemu/plugins/:' \
+ sed -i \
+ -e 's:Plugin/:/usr/lib/psemu/plugins/:' \
-e 's:Bios/:/usr/lib/psemu/bios/:' \
-e 's:Pcsx.cfg:~/.pcsx/config:' \
- <LnxMain.c >LnxMain.tmp
- mv -f LnxMain.tmp LnxMain.c
+ LnxMain.c || die "sed LnxMain.c failed"
for f in `find ${WORKDIR} -regex '.*\.[ch]'` ; do
- cp ${f}{,.old}
- sed -e 's/ $//' ${f}.old > ${f}
+ sed -i -e 's/ $//' ${f} || die "sed ${f} failed"
done
- emake CC=gcc OPTIMIZE="${CFLAGS} -fPIC -fomit-frame-pointer -finline-functions -ffast-math" || die
+ emake CC=gcc OPTIMIZE="${CFLAGS} -fPIC -fomit-frame-pointer -finline-functions -ffast-math" || die "emake failed"
mv pcsx pcsx.bin
}