summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-09-07 10:24:39 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-09-07 10:24:39 +0000
commit0f0c7eda36d51abd48fa3ff0dc51b25038179250 (patch)
tree43c7629dd2a7cc30fe6418446432e16a5517eac6 /app-emacs
parentclean up (diff)
downloadgentoo-2-0f0c7eda36d51abd48fa3ff0dc51b25038179250.tar.gz
gentoo-2-0f0c7eda36d51abd48fa3ff0dc51b25038179250.tar.bz2
gentoo-2-0f0c7eda36d51abd48fa3ff0dc51b25038179250.zip
clean up
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/python-mode/ChangeLog6
-rw-r--r--app-emacs/python-mode/files/60python-mode-gentoo.el16
-rw-r--r--app-emacs/python-mode/python-mode-1.0-r1.ebuild56
3 files changed, 5 insertions, 73 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index b30bf7c332e1..1e3eaf5452ac 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/python-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.44 2009/09/06 16:32:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.45 2009/09/07 10:24:39 fauli Exp $
+
+ 07 Sep 2009; Christian Faulhammer <fauli@gentoo.org>
+ -files/60python-mode-gentoo.el, -python-mode-1.0-r1.ebuild:
+ clean up
06 Sep 2009; Brent Baude <ranger@gentoo.org> python-mode-5.1.0.ebuild:
Marking python-mode-5.1.0 ppc64 for bug 272474
diff --git a/app-emacs/python-mode/files/60python-mode-gentoo.el b/app-emacs/python-mode/files/60python-mode-gentoo.el
deleted file mode 100644
index 1dddc571eb1a..000000000000
--- a/app-emacs/python-mode/files/60python-mode-gentoo.el
+++ /dev/null
@@ -1,16 +0,0 @@
-
-;;; python-mode site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-
-(autoload 'python-mode "python-mode" "Python editing mode." t)
-(autoload 'jython-mode "python-mode" "Python editing mode." t)
-(autoload 'py-shell "python-mode" "Start an interactive Python interpreter in another window." t)
-(autoload 'doctest-mode "doctest-mode" "Editing mode for Python Doctest examples." t)
-(autoload 'py-complete "pycomplete" "Complete a symbol at point using Pymacs." t)
-
-(add-to-list 'auto-mode-alist '("\\.py$" . python-mode))
-(add-to-list 'auto-mode-alist '("\\.doctest$" . doctest-mode))
-
-(add-to-list 'interpreter-mode-alist '("python" . python-mode))
-(add-to-list 'interpreter-mode-alist '("jython" . jython-mode))
diff --git a/app-emacs/python-mode/python-mode-1.0-r1.ebuild b/app-emacs/python-mode/python-mode-1.0-r1.ebuild
deleted file mode 100644
index 1ab8c1656344..000000000000
--- a/app-emacs/python-mode/python-mode-1.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-1.0-r1.ebuild,v 1.7 2008/09/20 17:59:06 vapier Exp $
-
-inherit elisp distutils
-
-DESCRIPTION="An Emacs major mode for editing Python source"
-HOMEPAGE="http://sourceforge.net/projects/python-mode/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="amd64 arm ~hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd"
-IUSE="pymacs"
-
-DEPEND="pymacs? ( app-emacs/pymacs )"
-RDEPEND="${DEPEND}"
-
-SITEFILE=60${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- if use pymacs; then
- cp "${FILESDIR}"/setup.py "${S}"
- else
- rm -f "${S}"/pycomplete.{el,py}
- fi
-}
-
-src_compile() {
- elisp_src_compile
- use pymacs && distutils_src_compile
-}
-
-src_install() {
- elisp-install ${PN} *.{el,elc} || die
- if use pymacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- distutils_src_install
- else
- # remove autoload for pycomplete from site file
- sed '/pycomplete/d' "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" \
- || die "sed failed"
- elisp-site-file-install "${T}/${SITEFILE}" || die
- fi
-}
-
-pkg_postinst() {
- elisp_pkg_postinst
- use pymacs && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- elisp_pkg_postrm
- use pymacs && distutils_pkg_postrm
-}