summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-03-19 18:27:43 +0000
committerUlrich Müller <ulm@gentoo.org>2012-03-19 18:27:43 +0000
commit21c16c5792a21d7b4bb6fd948ae4d1772893921a (patch)
tree47fd2cf0dba44df218a46f8bf71a02f78e7c3ad4 /app-emacs/nxml-libvirt-schemas
parentVersion bump. Update HOMEPAGE. Remove old. (diff)
downloadgentoo-2-21c16c5792a21d7b4bb6fd948ae4d1772893921a.tar.gz
gentoo-2-21c16c5792a21d7b4bb6fd948ae4d1772893921a.tar.bz2
gentoo-2-21c16c5792a21d7b4bb6fd948ae4d1772893921a.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas')
-rw-r--r--app-emacs/nxml-libvirt-schemas/ChangeLog10
-rw-r--r--app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el3
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild57
3 files changed, 65 insertions, 5 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/ChangeLog b/app-emacs/nxml-libvirt-schemas/ChangeLog
index 7d6ee63e1030..5846e2c9d23c 100644
--- a/app-emacs/nxml-libvirt-schemas/ChangeLog
+++ b/app-emacs/nxml-libvirt-schemas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/nxml-libvirt-schemas
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.7 2011/03/28 07:58:56 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/ChangeLog,v 1.8 2012/03/19 18:27:43 ulm Exp $
+
+*nxml-libvirt-schemas-0.9.7 (19 Mar 2012)
+
+ 19 Mar 2012; Ulrich Müller <ulm@gentoo.org>
+ +nxml-libvirt-schemas-0.9.7.ebuild:
+ Version bump.
*nxml-libvirt-schemas-0.9.0_rc1 (28 Mar 2011)
diff --git a/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el b/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el
index 6f41677d3ac0..c574746e6576 100644
--- a/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el
+++ b/app-emacs/nxml-libvirt-schemas/files/60nxml-libvirt-schemas-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; nxml-svg-schemas site-lisp configuration
-
;; This must be executed after rng-schema-locating-files
;; is set in rng-loc (which is part of nxml-mode).
(eval-after-load "rng-loc"
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild
new file mode 100644
index 000000000000..bf4a9490fd0f
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-0.9.7.ebuild,v 1.1 2012/03/19 18:27:43 ulm Exp $
+
+EAPI=4
+
+#BACKPORTS=
+NEED_EMACS=23
+
+inherit elisp eutils
+
+MY_P="libvirt-${PV/_rc/-rc}"
+
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="http://www.libvirt.org/"
+SRC_URI="http://libvirt.org/sources/${MY_P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${MY_P}-backports-${BACKPORTS}.tar.bz2}"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+SITEFILE="60${PN}-gentoo.el"
+S="${WORKDIR}/${MY_P%-rc*}"
+
+src_prepare() {
+ if [[ -d "${WORKDIR}/patches" ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+ fi
+}
+
+src_compile() {
+ emake -C docs/schemas -f "${FILESDIR}/Makefile-trang"
+}
+
+src_test() {
+ # No we don't need tests here... trang will take care of checking
+ # the well-formedness of the schema files for us
+ :
+}
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}/schemas.xml" docs/schemas/*.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}