summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-07-15 18:08:12 +0000
committerTom Gall <tgall@gentoo.org>2004-07-15 18:08:12 +0000
commit344fce3747769a2794bdad2d3821ea336be71d99 (patch)
tree57da390f72dbc1979d81d643d22457d7c65a0334 /app-editors
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-344fce3747769a2794bdad2d3821ea336be71d99.tar.gz
gentoo-2-344fce3747769a2794bdad2d3821ea336be71d99.tar.bz2
gentoo-2-344fce3747769a2794bdad2d3821ea336be71d99.zip
added ~ppc64, bug #55328
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog5
-rw-r--r--app-editors/emacs/emacs-21.3-r4.ebuild5
-rw-r--r--app-editors/emacs/files/emacs-21.3-ppc64.patch51
3 files changed, 58 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 200396a7d8d9..9a26521b4665 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.30 2004/07/04 14:15:47 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.31 2004/07/15 18:08:12 tgall Exp $
+
+ 15 Jul 2004; Tom Gall <tgall@gentoo.org> emacs-21.3-r4.ebuild:
+ added ~ppc64 bug #55328
*emacs-21.3-r4 (04 Jul 2004)
diff --git a/app-editors/emacs/emacs-21.3-r4.ebuild b/app-editors/emacs/emacs-21.3-r4.ebuild
index cd856d83d665..a284249a1dcb 100644
--- a/app-editors/emacs/emacs-21.3-r4.ebuild
+++ b/app-editors/emacs/emacs-21.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.1 2004/07/04 14:15:47 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.2 2004/07/15 18:08:12 tgall Exp $
inherit flag-o-matic eutils alternatives
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.gz
LICENSE="GPL-2"
SLOT="${PV}"
-KEYWORDS="~x86 ~ppc ~sparc -alpha ~arm -hppa ~amd64 -ia64 ~s390"
+KEYWORDS="~x86 ~ppc ~sparc -alpha ~arm -hppa ~amd64 -ia64 ~s390 ~ppc64"
IUSE="X nls motif leim gnome Xaw3d lesstif"
RDEPEND="sys-libs/ncurses
@@ -45,6 +45,7 @@ src_compile() {
epatch ${FILESDIR}/${P}-amd64.patch
epatch ${FILESDIR}/${P}-hppa.patch
+ use ppc64 && epatch ${FILESDIR}/${P}-ppc64.patch
export WANT_AUTOCONF=2.1
autoconf
diff --git a/app-editors/emacs/files/emacs-21.3-ppc64.patch b/app-editors/emacs/files/emacs-21.3-ppc64.patch
new file mode 100644
index 000000000000..757213794b59
--- /dev/null
+++ b/app-editors/emacs/files/emacs-21.3-ppc64.patch
@@ -0,0 +1,51 @@
+--- emacs-21.3/src/m/macppc.h.sopwith 2001-10-23 02:43:33.000000000 -0400
++++ emacs-21.3/src/m/macppc.h 2003-05-02 09:17:37.000000000 -0400
+@@ -95,11 +95,47 @@
+
+ #ifdef LINUX
+ #define LINKER $(CC) -nostdlib
+-#define LD_SWITCH_MACHINE -Xlinker -m -Xlinker elf32ppc
++#ifdef __powerpc64__
++#define LD_SWITCH_MACHINE -m64 -Xlinker -m -Xlinker elf64ppc
++#else
++#define LD_SWITCH_MACHINE -m32 -Xlinker -m -Xlinker elf32ppc
++#endif
+ /* s/gnu-linux.h defines this to `-z nocombreloc' which does not work here
+ because prefix-args is not used. */
+ #undef LD_SWITCH_SYSTEM_TEMACS
+ #define LD_SWITCH_MACHINE_TEMACS -Xlinker -znocombreloc
++
++#ifdef __powerpc64__
++/* Misc 64-bit fixups, patterned after the x86_64 file */
++#undef BITS_PER_LONG
++#undef BITS_PER_EMACS_INT
++#undef VALBITS
++#undef PNTR_COMPARISON_TYPE
++#undef MARKBIT
++#undef XINT
++#undef XUINT
++#undef XPNTR
++#undef START_FILES
++#undef LIB_STANDARD
++#undef EMACS_INT
++#undef EMACS_UINT
++#undef SPECIAL_EMACS_INT
++
++#define BITS_PER_LONG 64
++#define BITS_PER_EMACS_INT 64
++#define VALBITS 60
++#define PNTR_COMPARISON_TYPE unsigned long
++#define MARKBIT 0x8000000000000000L
++
++#define XINT(a) (((long) (a) << (BITS_PER_LONG - VALBITS)) >> (BITS_PER_LONG - VALBITS))
++#define XUINT(a) ((long) (a) & VALMASK)
++#define XPNTR(a) XUINT (a)
++#define START_FILES pre-crt0.o /usr/lib64/crt1.o /usr/lib64/crti.o
++#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib64/crtn.o
++#define EMACS_INT long
++#define EMACS_UINT unsigned long
++#define SPECIAL_EMACS_INT
++#endif
+ #endif
+
+ #if 0 /* This breaks things on PPC GNU/Linux ecept for Yellowdog,