summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-04-09 00:33:58 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-04-09 00:33:58 +0000
commit4cf6ad786028929ed5cd05258dad8aea1e54f33b (patch)
treef20d345d4f527330e47b5eb1509d531162c65440 /app-doc
parentversion bump (diff)
downloadgentoo-2-4cf6ad786028929ed5cd05258dad8aea1e54f33b.tar.gz
gentoo-2-4cf6ad786028929ed5cd05258dad8aea1e54f33b.tar.bz2
gentoo-2-4cf6ad786028929ed5cd05258dad8aea1e54f33b.zip
QT environment fixes for bug 127596, plus updates for bugs 126374 and 127823
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog8
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild9
-rw-r--r--app-doc/doxygen/doxygen-1.4.3-r1.ebuild9
-rw-r--r--app-doc/doxygen/doxygen-1.4.4.ebuild9
-rw-r--r--app-doc/doxygen/doxygen-1.4.5.ebuild9
-rw-r--r--app-doc/doxygen/doxygen-1.4.6.ebuild28
-rw-r--r--app-doc/doxygen/metadata.xml7
7 files changed, 40 insertions, 39 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index ef3db8abf77a..9fdc6ee82a2c 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.96 2006/04/05 12:09:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.97 2006/04/09 00:33:58 nerdboy Exp $
+
+ 08 Apr 2006; Steve Arnold <nerdboy@gentoo.org> doxygen-1.4.2.ebuild,
+ doxygen-1.4.3-r1.ebuild, doxygen-1.4.4.ebuild, doxygen-1.4.5.ebuild,
+ doxygen-1.4.6.ebuild:
+ Updated QT environment stuff to address bug 127596, as well as updates
+ for bugs 126374 and 127823 (1.4.6 only).
05 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Recommit manifest, connection lost during commit.
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
index 588ae9be6264..da32cca38dcc 100644
--- a/app-doc/doxygen/doxygen-1.4.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.16 2006/02/08 08:47:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.17 2006/04/09 00:33:58 nerdboy Exp $
-inherit eutils toolchain-funcs kde-functions
+inherit eutils toolchain-funcs qt3
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -15,13 +15,11 @@ KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sparc x86"
IUSE="doc qt tetex unicode"
DEPEND="media-gfx/graphviz
- qt? ( =x11-libs/qt-3* )
+ qt? ( $(qt_min_version 3.3) )
tetex? ( virtual/tetex )
virtual/ghostscript
>=sys-apps/sed-4"
-if use qt; then need-qt 3; fi
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -49,7 +47,6 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- einfo "using QT version: '$QTVER'."
einfo "using QTDIR: '$QTDIR'."
export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
diff --git a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
index 26ed024f7c9c..5074295a081f 100644
--- a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.11 2006/02/08 08:47:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.12 2006/04/09 00:33:58 nerdboy Exp $
-inherit eutils toolchain-funcs kde-functions
+inherit eutils toolchain-funcs qt3
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -15,14 +15,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc x86 ~ppc-
IUSE="doc qt tetex unicode"
RDEPEND="media-gfx/graphviz
- qt? ( =x11-libs/qt-3* )
+ qt? ( $(qt_min_version 3.3) )
tetex? ( virtual/tetex )
virtual/ghostscript"
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
-if use qt; then need-qt 3; fi
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -53,7 +51,6 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- einfo "using QT version: '$QTVER'."
einfo "using QTDIR: '$QTDIR'."
export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
diff --git a/app-doc/doxygen/doxygen-1.4.4.ebuild b/app-doc/doxygen/doxygen-1.4.4.ebuild
index d18ed47d9a97..63669704b271 100644
--- a/app-doc/doxygen/doxygen-1.4.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.17 2006/02/08 08:47:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.4.ebuild,v 1.18 2006/04/09 00:33:58 nerdboy Exp $
-inherit eutils toolchain-funcs kde-functions
+inherit eutils toolchain-funcs qt3
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -15,14 +15,12 @@ KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
IUSE="doc qt tetex unicode"
RDEPEND="media-gfx/graphviz
- qt? ( =x11-libs/qt-3* )
+ qt? ( $(qt_min_version 3.3) )
tetex? ( virtual/tetex )
virtual/ghostscript"
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
-if use qt; then need-qt 3; fi
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -47,7 +45,6 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- einfo "using QT version: '$QTVER'."
einfo "using QTDIR: '$QTDIR'."
export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
diff --git a/app-doc/doxygen/doxygen-1.4.5.ebuild b/app-doc/doxygen/doxygen-1.4.5.ebuild
index 76447af80cbd..4726b0ea15e5 100644
--- a/app-doc/doxygen/doxygen-1.4.5.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.6 2006/02/08 08:47:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.5.ebuild,v 1.7 2006/04/09 00:33:58 nerdboy Exp $
-inherit eutils toolchain-funcs kde-functions
+inherit eutils toolchain-funcs qt3
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -15,14 +15,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc
IUSE="doc qt tetex unicode"
RDEPEND=">=media-gfx/graphviz-2.6
- qt? ( =x11-libs/qt-3* )
+ qt? ( $(qt_min_version 3.3) )
tetex? ( virtual/tetex )
virtual/ghostscript"
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
-if use qt; then need-qt 3; fi
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -47,7 +45,6 @@ src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- einfo "using QT version: '$QTVER'."
einfo "using QTDIR: '$QTDIR'."
export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
diff --git a/app-doc/doxygen/doxygen-1.4.6.ebuild b/app-doc/doxygen/doxygen-1.4.6.ebuild
index 36da4b4bdf7c..1b556b6538fa 100644
--- a/app-doc/doxygen/doxygen-1.4.6.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.6.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.4 2006/04/05 11:29:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.6.ebuild,v 1.5 2006/04/09 00:33:58 nerdboy Exp $
-inherit eutils toolchain-funcs kde-functions
+inherit eutils toolchain-funcs qt3
-DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, Objective-C,
+ Python, IDL , and other C-like languages."
HOMEPAGE="http://www.doxygen.org/"
SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz
unicode? ( mirror://gentoo/${PN}-utf8-ru.patch.gz )"
@@ -15,24 +16,22 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc
IUSE="doc qt tetex unicode"
RDEPEND=">=media-gfx/graphviz-2.6
- qt? ( =x11-libs/qt-3* )
+ qt? ( $(qt_min_version 3.3) )
tetex? ( virtual/tetex )
virtual/ghostscript"
DEPEND=">=sys-apps/sed-4
${RDEPEND}"
-if use qt; then need-qt 3; fi
-
src_unpack() {
unpack ${A}
cd ${S}
- # use CFLAGS and CXXFLAGS (on linux and ppc-macos)
- sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
- -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
- tmake/lib/{linux-g++,macosx-c++}/tmake.conf
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf
epatch ${FILESDIR}/doxygen-1.4.3-cp1251.patch
-# epatch ${FILESDIR}/doxygen-1.4.4-darwin.patch
if use unicode; then
epatch ${WORKDIR}/${PN}-utf8-ru.patch || die "utf8-ru patch failed"
@@ -47,10 +46,10 @@ src_unpack() {
}
src_compile() {
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
# set ./configure options (prefix, Qt based wizard, docdir)
local my_conf="--prefix ${D}usr"
if use qt; then
- einfo "using QT version: '$QTVER'."
einfo "using QTDIR: '$QTDIR'."
export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
@@ -62,7 +61,8 @@ src_compile() {
fi
# and compile
- emake all || die 'emake failed'
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
+ LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
# generate html and pdf (if tetex in use) documents.
# errors here are not considered fatal, hence the ewarn message
@@ -110,5 +110,7 @@ pkg_postinst() {
einfo "and other goodies, see the source tarball. For some example"
einfo "output, run doxygen on the doxygen source using the Doxyfile"
einfo "provided in the top-level source dir."
+ einfo ""
+ einfo "See the Doxygen homepage for additional language support tools."
ewarn
}
diff --git a/app-doc/doxygen/metadata.xml b/app-doc/doxygen/metadata.xml
index be7ddc695383..bcfecf8998f9 100644
--- a/app-doc/doxygen/metadata.xml
+++ b/app-doc/doxygen/metadata.xml
@@ -6,5 +6,10 @@
<email>nerdboy@gentoo.org</email>
<name>Steve Arnold</name>
</maintainer>
-<longdescription>Doxygen is a tool for analyzing, documenting, and reverse-engineering source code of various languages using a variety of output formats (try it and see).</longdescription>
+<longdescription>Doxygen is a tool for analyzing, documenting, and reverse-engineering
+ source code of various languages using a variety of output formats
+ (try it and see). Doxygen supports C++, C, Java, Objective-C, Python,
+ IDL (Corba and Microsoft flavors) and to some extent PHP, C#, and D,
+ as well as other languages (using additional helper tools).
+</longdescription>
</pkgmetadata>