summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-07-16 14:04:46 +0000
committerMichał Górny <mgorny@gentoo.org>2011-07-16 14:04:46 +0000
commitcafae6dad875df72f9d26628d502ef80192506bb (patch)
treea6850330e45a0344c218b3e6f4e2a65963cde78a /app-doc/pms
parentVersion bump (diff)
downloadgentoo-2-cafae6dad875df72f9d26628d502ef80192506bb.tar.gz
gentoo-2-cafae6dad875df72f9d26628d502ef80192506bb.tar.bz2
gentoo-2-cafae6dad875df72f9d26628d502ef80192506bb.zip
Migrate the live ebuild to git-2.eclass, add a fallback EGIT_REPO_URI, bump EAPI.
(Portage version: 2.2.0_alpha45_p2/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/pms')
-rw-r--r--app-doc/pms/ChangeLog6
-rw-r--r--app-doc/pms/pms-9999.ebuild22
2 files changed, 15 insertions, 13 deletions
diff --git a/app-doc/pms/ChangeLog b/app-doc/pms/ChangeLog
index 4b91151c1b1e..ed4922261a47 100644
--- a/app-doc/pms/ChangeLog
+++ b/app-doc/pms/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/pms
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/ChangeLog,v 1.29 2011/03/18 19:38:42 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/ChangeLog,v 1.30 2011/07/16 14:04:46 mgorny Exp $
+
+ 16 Jul 2011; Michał Górny <mgorny@gentoo.org> pms-9999.ebuild:
+ Migrate the live ebuild to git-2.eclass, add a fallback EGIT_REPO_URI, bump
+ EAPI.
18 Mar 2011; Ulrich Mueller <ulm@gentoo.org> pms-4_p20110118.ebuild:
Mark as stable, bug 359359.
diff --git a/app-doc/pms/pms-9999.ebuild b/app-doc/pms/pms-9999.ebuild
index 463aa5d34fba..47104405dd30 100644
--- a/app-doc/pms/pms-9999.ebuild
+++ b/app-doc/pms/pms-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/pms-9999.ebuild,v 1.1 2010/06/11 13:48:10 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/pms/pms-9999.ebuild,v 1.2 2011/07/16 14:04:46 mgorny Exp $
-inherit git
+EAPI=4
+inherit git-2
-EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/pms.git"
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git
+ http://git.overlays.gentoo.org/gitroot/proj/${PN}.git"
DESCRIPTION="Gentoo Package Manager Specification (draft)"
HOMEPAGE="http://www.gentoo.org/proj/en/qa/pms.xml"
@@ -25,15 +27,11 @@ DEPEND="html? ( >=dev-tex/tex4ht-20090115_p0029 )
RDEPEND=""
src_compile() {
- emake || die
- if use html; then
- emake html || die
- fi
+ emake
+ use html && emake html
}
src_install() {
- dodoc pms.pdf || die
- if use html; then
- dohtml *.html pms.css $(shopt -s nullglob; echo *.png) || die
- fi
+ dodoc pms.pdf
+ use html && dohtml *.html pms.css $(shopt -s nullglob; echo *.png)
}