summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-01-07 20:05:17 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-01-07 20:05:17 +0000
commit7377cc8408e0a6614b91e1a4552324cf610d507e (patch)
treebfd8b83a372691590b0ae6955722b6a717341e16 /app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild
parentstablize newer revision. add newer revision for MythEvent redirecting fix (diff)
downloadgentoo-2-7377cc8408e0a6614b91e1a4552324cf610d507e.tar.gz
gentoo-2-7377cc8408e0a6614b91e1a4552324cf610d507e.tar.bz2
gentoo-2-7377cc8408e0a6614b91e1a4552324cf610d507e.zip
Version bump, bug#204771
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild')
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild
new file mode 100644
index 000000000000..c0aa1c634fc4
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-tools/tpm-tools-1.3.1.ebuild,v 1.1 2008/01/07 20:05:17 alonbl Exp $
+
+inherit autotools
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+COMMON_DEPEND=">=app-crypt/trousers-0.3.0"
+DEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )"
+# TODO: add optionnal opencryptoki support
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}