summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-07 13:17:51 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-11-07 13:17:51 +0000
commitb323c9d4f7e34d78d93880056c5395f14c68c759 (patch)
treefd5358ba36b8e3c8434747fa9b7e94e6a74b1e58 /app-crypt/keynote
parentstable ppc, bug #441420 (diff)
downloadgentoo-2-b323c9d4f7e34d78d93880056c5395f14c68c759.tar.gz
gentoo-2-b323c9d4f7e34d78d93880056c5395f14c68c759.tar.bz2
gentoo-2-b323c9d4f7e34d78d93880056c5395f14c68c759.zip
Respect CFLAGS wrt bug #442146. Respect AR, migrate to EAPI 5.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'app-crypt/keynote')
-rw-r--r--app-crypt/keynote/ChangeLog9
-rw-r--r--app-crypt/keynote/files/keynote-2.3-qa.patch44
-rw-r--r--app-crypt/keynote/keynote-2.3-r3.ebuild49
3 files changed, 100 insertions, 2 deletions
diff --git a/app-crypt/keynote/ChangeLog b/app-crypt/keynote/ChangeLog
index 9dd0d876b7ad..b474daabe5cf 100644
--- a/app-crypt/keynote/ChangeLog
+++ b/app-crypt/keynote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/keynote
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.18 2012/06/07 21:17:19 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.19 2012/11/07 13:17:51 kensington Exp $
+
+*keynote-2.3-r3 (07 Nov 2012)
+
+ 07 Nov 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/keynote-2.3-qa.patch, +keynote-2.3-r3.ebuild:
+ Respect CFLAGS wrt bug #442146. Respect AR, migrate to EAPI 5.
07 Jun 2012; Johannes Huber <johu@gentoo.org> -keynote-2.3.ebuild:
Remove old.
@@ -58,4 +64,3 @@
23 Dec 2003; <plasmaroo@gentoo.org> keynote-2.3.ebuild:
Initial commit. This ebuild was kindly contributed by Sebastien
Estienne, bug #27279.
-
diff --git a/app-crypt/keynote/files/keynote-2.3-qa.patch b/app-crypt/keynote/files/keynote-2.3-qa.patch
new file mode 100644
index 000000000000..f6b1ff28cdb8
--- /dev/null
+++ b/app-crypt/keynote/files/keynote-2.3-qa.patch
@@ -0,0 +1,44 @@
+Respect CFLAGS, LDFLAGS, and AR.
+
+The better way to fix AR would be to patch configure.in,
+but it is sufficiently old to fail with current autotools.
+--- Makefile.in
++++ Makefile.in
+@@ -27,7 +27,6 @@
+ YACC = @YACC@
+ SSLEAY = @SSLEAY@
+ RM = @RM@
+-AR = @AR@
+ NROFF = @NROFF@
+ TAR = @TAR@
+ TRUE = @TRUE@
+@@ -41,10 +40,10 @@
+ YACCFLAGS = -d -p kn -b k
+ LEXFLAGS2 = -Pkv -s -i
+ LEXFLAGS = -Cr -Pkn -s -i
+-CFLAGS = -O2 -Wall # -g
+ RMFLAGS2 = -rf
+ RMFLAGS = -f
+ NROFFFLAGS = -mandoc
++LDFLAGS = @LDFLAGS@
+
+ SSLCONF = testsuite/openssl.cnf
+ SSLCERT = testsuite/test.cert.pem
+@@ -83,7 +82,7 @@
+ $(RANLIB) $(TARGET)
+
+ $(TARGET2): $(TARGET) $(OBJS2)
+- $(CC) $(CFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET2) $(OBJS2) $(LIBS)
+
+ k.tab.c: keynote.y header.h keynote.h assertion.h config.h
+ $(YACC) $(YACCFLAGS) keynote.y
+@@ -131,7 +130,7 @@
+ -keyout $(SSLKEY)
+
+ test-sample: all $(OBJS3)
+- $(CC) $(CFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET3) $(OBJS3) $(LIBS)
+
+ test-sig: all $(SSLCERT) $(SSLKEY)
+ $(SED) -e 's/--.*//' < $(SSLCERT) > $(SSLCERT).1
diff --git a/app-crypt/keynote/keynote-2.3-r3.ebuild b/app-crypt/keynote/keynote-2.3-r3.ebuild
new file mode 100644
index 000000000000..c5b69b28ad4a
--- /dev/null
+++ b/app-crypt/keynote/keynote-2.3-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3-r3.ebuild,v 1.1 2012/11/07 13:17:51 kensington Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The KeyNote Trust-Management System"
+HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
+SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+pkg_setup() {
+ tc-export AR CC RANLIB
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qa.patch
+ epatch "${FILESDIR}"/${P}-parallel-build.patch
+}
+
+src_compile() {
+ if use ssl; then
+ emake
+ else
+ emake nocrypto
+ fi
+}
+
+src_install() {
+ dobin keynote
+
+ dolib.a libkeynote.a
+
+ insinto /usr/include
+ doins keynote.h
+
+ doman man/keynote.[1345]
+ dodoc README HOWTO.add.crypto TODO
+}