summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-02 04:19:21 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-02 04:19:21 +0000
commitc4951ba8cc6f884d01275a74b50c191e109e820c (patch)
tree7b1c851ca234f06c666756e0d0f526e952d84fe5 /app-crypt/gpgme
parentFix automake-1.13 compability wrt #467778 by "Vamp898" (diff)
downloadgentoo-2-c4951ba8cc6f884d01275a74b50c191e109e820c.tar.gz
gentoo-2-c4951ba8cc6f884d01275a74b50c191e109e820c.tar.bz2
gentoo-2-c4951ba8cc6f884d01275a74b50c191e109e820c.zip
Version bump, update to EAPI 5 and add subslot.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/ChangeLog7
-rw-r--r--app-crypt/gpgme/gpgme-1.4.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index 1946f93b51ac..3d4b8ac41db4 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gpgme
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.203 2013/03/06 11:34:45 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.204 2013/05/02 04:19:21 radhermit Exp $
+
+*gpgme-1.4.1 (02 May 2013)
+
+ 02 May 2013; Tim Harder <radhermit@gentoo.org> +gpgme-1.4.1.ebuild:
+ Version bump, update to EAPI 5 and add subslot.
*gpgme-1.4.0 (06 Mar 2013)
diff --git a/app-crypt/gpgme/gpgme-1.4.1.ebuild b/app-crypt/gpgme/gpgme-1.4.1.ebuild
new file mode 100644
index 000000000000..74a12a082bf8
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.4.1.ebuild,v 1.1 2013/05/02 04:19:21 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-2.0.2
+ >=dev-libs/libgpg-error-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ --with-gpg="${EPREFIX}/usr/bin/gpg" \
+ --with-gpgsm="${EPREFIX}/usr/bin/gpgsm" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}