summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-27 18:02:11 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-27 18:02:11 +0000
commit86a2760009ef574433ae717a50b45d56e4d943bb (patch)
tree51b836dd7e97935d27beddfa3dac79b7ada7cfd2 /app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
parentFix quoting too. (diff)
downloadgentoo-2-86a2760009ef574433ae717a50b45d56e4d943bb.tar.gz
gentoo-2-86a2760009ef574433ae717a50b45d56e4d943bb.tar.bz2
gentoo-2-86a2760009ef574433ae717a50b45d56e4d943bb.zip
Respect build settings #248714 by Diego E. Pettenò and touchup rar DEPEND #244989 by drantin.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild')
-rw-r--r--app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild b/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
index 01d1bf2f83b7..64852a5ff6ae 100644
--- a/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
+++ b/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild
@@ -1,38 +1,40 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild,v 1.2 2008/06/14 16:13:13 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xdvdfs-tools/xdvdfs-tools-2.1-r1.ebuild,v 1.3 2008/11/27 18:02:11 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Tools for manipulating Xbox ISO images"
HOMEPAGE="http://www.layouts.xbox-scene.com/"
-SRC_URI="http://www.layouts.xbox-scene.com/main/files/XDVDFSToolsv2.1.rar"
+SRC_URI="http://www.layouts.xbox-scene.com/main/files/XDVDFSToolsv${PV}.rar"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-DEPEND="app-arch/unrar"
+DEPEND="|| ( app-arch/unrar app-arch/rar )"
RDEPEND=""
S=${WORKDIR}/XDVDFS_Tools/src
src_unpack() {
- unrar x "${DISTDIR}"/XDVDFSToolsv${PV}.rar
+ unpack ${A}
mv "XDVDFS Tools" XDVDFS_Tools
- sed -i -e "s:CCFLAGS = .*:CCFLAGS = ${CFLAGS}:g" "${S}"/makefile.prefab
+ sed -i \
+ -e '/^LDFLAGS = -s/d' \
+ -e '/^CCFLAGS =/s:=.*:= ${CFLAGS} ${CPPFLAGS}:g' \
+ -e "/^CC =/s:=.*:=$(tc-getCC):" \
+ "${S}"/makefile.prefab
epatch "${FILESDIR}"/${P}-fnamefix.patch
mkdir "${S}"/xdvdfs_extract/output "${S}"/xdvdfs_maker/output
}
src_compile() {
- cd "${S}"/xdvdfs_dumper
- emake || die "xdvdfs_dumper"
- cd ../xdvdfs_extract
- emake || die "xdvdfs_extract"
- cd ../xdvdfs_maker
- emake || die "xdvdfs_maker"
+ local d
+ for d in xdvdfs_{dumper,extract,maker} ; do
+ emake -C ${d} || die
+ done
}
src_install() {