summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-09-25 01:38:09 +0000
committerMichael Weber <xmw@gentoo.org>2011-09-25 01:38:09 +0000
commitaa161c0079c06fc02378024daca6378995c51f81 (patch)
tree8e082d2d4094df1719af49261172f5faf103d3e4 /app-backup
parentfix 384377 (diff)
downloadgentoo-2-aa161c0079c06fc02378024daca6378995c51f81.tar.gz
gentoo-2-aa161c0079c06fc02378024daca6378995c51f81.tar.bz2
gentoo-2-aa161c0079c06fc02378024daca6378995c51f81.zip
Improved python code and version bump (thanks to Milton Yates for the detailed report on bug 382287), taking care of this one
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/backintime/ChangeLog11
-rw-r--r--app-backup/backintime/backintime-1.0.6-r1.ebuild98
-rw-r--r--app-backup/backintime/backintime-1.0.6.ebuild50
-rw-r--r--app-backup/backintime/backintime-1.0.8.ebuild98
-rw-r--r--app-backup/backintime/files/backintime-1.0.6-wrapper.patch45
-rw-r--r--app-backup/backintime/metadata.xml3
6 files changed, 280 insertions, 25 deletions
diff --git a/app-backup/backintime/ChangeLog b/app-backup/backintime/ChangeLog
index 6e6197d6f111..0a1c7ff32ed0 100644
--- a/app-backup/backintime/ChangeLog
+++ b/app-backup/backintime/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-backup/backintime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.11 2011/07/20 17:11:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/ChangeLog,v 1.12 2011/09/25 01:38:09 xmw Exp $
+
+*backintime-1.0.8 (25 Sep 2011)
+*backintime-1.0.6-r1 (25 Sep 2011)
+
+ 25 Sep 2011; Michael Weber <xmw@gentoo.org> backintime-1.0.6.ebuild,
+ +backintime-1.0.6-r1.ebuild, +files/backintime-1.0.6-wrapper.patch,
+ +backintime-1.0.8.ebuild, metadata.xml:
+ Improved python code and version bump (thanks to Milton Yates for the
+ detailed report on bug 382287), taking care of this one
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #118937
diff --git a/app-backup/backintime/backintime-1.0.6-r1.ebuild b/app-backup/backintime/backintime-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..6f7b26aea546
--- /dev/null
+++ b/app-backup/backintime/backintime-1.0.6-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.6-r1.ebuild,v 1.1 2011/09/25 01:38:09 xmw Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="http://backintime.le-web.org/"
+SRC_URI="http://backintime.le-web.org/download/${PN}/${P}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde gnome"
+
+DEPEND="
+ net-misc/rsync[xattr,acl]
+ kde? (
+ >=kde-base/kdelibs-4
+ kde-base/pykde4
+ kde-base/kompare
+ kde-base/kdesu
+ )
+ gnome? (
+ gnome-base/libglade
+ dev-util/meld
+ gnome-base/gnome-session
+ dev-python/gnome-vfs-python
+ dev-python/libgnome-python
+ dev-python/pygobject
+ dev-python/pygtk
+ )
+ dev-python/notify-python"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.4-dont-install-license.diff
+ epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
+ #fix doc install location
+ sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
+ sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
+
+ cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
+ kde4/backintime-kde4-root.desktop || die
+
+ epatch "${FILESDIR}"/${P}-wrapper.patch
+ sed -e "/^python /s:^python:$(PYTHON -a):" \
+ -e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
+ -i common/backintime \
+ -i gnome/backintime-gnome \
+ -i kde4/backintime-kde4 || die
+}
+
+src_configure() {
+ cd "${S}"/common || die
+ econf
+
+ if use kde ; then
+ cd "${S}"/kde4 || die
+ econf
+ fi
+
+ if use gnome ; then
+ cd "${S}"/gnome || die
+ econf
+ fi
+}
+
+src_compile() {
+ emake -C common || die
+
+ if use kde ; then
+ emake -C kd4 || die
+ fi
+
+ if use gnome ; then
+ emake -C gnome || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C common install || die
+
+ if use kde ; then
+ emake DESTDIR="${D}" -C kde4 install || die
+ fi
+
+ if use gnome ; then
+ emake DESTDIR="${D}" -C gnome install || die
+ fi
+
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+}
diff --git a/app-backup/backintime/backintime-1.0.6.ebuild b/app-backup/backintime/backintime-1.0.6.ebuild
index 96bd26dd5919..0674789a6998 100644
--- a/app-backup/backintime/backintime-1.0.6.ebuild
+++ b/app-backup/backintime/backintime-1.0.6.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.6.ebuild,v 1.1 2011/02/01 11:03:35 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.6.ebuild,v 1.2 2011/09/25 01:38:09 xmw Exp $
EAPI="3"
-inherit eutils
+PYTHON_DEPEND="2"
+
+inherit eutils python
DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
HOMEPAGE="http://backintime.le-web.org/"
@@ -15,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="kde gnome"
-DEPEND="dev-lang/python
+DEPEND="
net-misc/rsync[xattr,acl]
kde? (
>=kde-base/kdelibs-4
@@ -32,8 +34,7 @@ DEPEND="dev-lang/python
dev-python/pygobject
dev-python/pygtk
)
- dev-python/notify-python
- "
+ dev-python/notify-python"
RDEPEND="${DEPEND}"
@@ -41,54 +42,57 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.4-dont-install-license.diff
epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
#fix doc install location
- sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template
- sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template
+ sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
+ sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
- "${S}"/kde4/backintime-kde4-root.desktop
+ kde4/backintime-kde4-root.desktop || die
+
+ epatch "${FILESDIR}"/${P}-wrapper.patch
+ sed -e "/^python /s:^python:$(PYTHON -a):" \
+ -e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
+ -i common/backintime \
+ -i gnome/backintime-gnome \
+ -i kde4/backintime-kde4 || die
}
src_configure() {
- cd "${S}"/common
+ cd "${S}"/common || die
econf
if use kde ; then
- cd "${S}"/kde4
+ cd "${S}"/kde4 || die
econf
fi
if use gnome ; then
- cd "${S}"/gnome
+ cd "${S}"/gnome || die
econf
fi
}
src_compile() {
- cd "${S}"/common
- emake
+ emake -C common || die
if use kde ; then
- cd "${S}"/kde4
- emake
+ emake -C kd4 || die
fi
if use gnome ; then
- cd "${S}"/gnome
- emake
+ emake -C gnome || die
fi
}
src_install() {
- cd "${S}"/common
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" -C common install || die
if use kde ; then
- cd "${S}"/kde4
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" -C kde4 install || die
fi
if use gnome ; then
- cd "${S}"/gnome
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" -C gnome install || die
fi
+
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
}
diff --git a/app-backup/backintime/backintime-1.0.8.ebuild b/app-backup/backintime/backintime-1.0.8.ebuild
new file mode 100644
index 000000000000..721ff12b058c
--- /dev/null
+++ b/app-backup/backintime/backintime-1.0.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/backintime/backintime-1.0.8.ebuild,v 1.1 2011/09/25 01:38:09 xmw Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="A simple backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
+HOMEPAGE="http://backintime.le-web.org/"
+SRC_URI="http://backintime.le-web.org/download/${PN}/${P}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde gnome"
+
+DEPEND="
+ net-misc/rsync[xattr,acl]
+ kde? (
+ >=kde-base/kdelibs-4
+ kde-base/pykde4
+ kde-base/kompare
+ kde-base/kdesu
+ )
+ gnome? (
+ gnome-base/libglade
+ dev-util/meld
+ gnome-base/gnome-session
+ dev-python/gnome-vfs-python
+ dev-python/libgnome-python
+ dev-python/pygobject
+ dev-python/pygtk
+ )
+ dev-python/notify-python"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.4-dont-install-license.diff
+ epatch "${FILESDIR}"/${PN}-1.0.4-fix-configure-warning.diff
+ #fix doc install location
+ sed -i "s:/doc/kde4/HTML/:/doc/HTML/:g" kde4/Makefile.template || die
+ sed -i "s:/doc/backintime:/doc/${PF}:g" common/Makefile.template || die
+
+ cp "${FILESDIR}"/backintime-1.0.4-kde4-root.desktop \
+ kde4/backintime-kde4-root.desktop || die
+
+ epatch "${FILESDIR}"/${PN}-1.0.6-wrapper.patch
+ sed -e "/^python /s:^python:$(PYTHON -a):" \
+ -e "/^APP_PATH=/s:/usr:${EPREFIX}/usr:" \
+ -i common/backintime \
+ -i gnome/backintime-gnome \
+ -i kde4/backintime-kde4 || die
+}
+
+src_configure() {
+ cd "${S}"/common || die
+ econf
+
+ if use kde ; then
+ cd "${S}"/kde4 || die
+ econf
+ fi
+
+ if use gnome ; then
+ cd "${S}"/gnome || die
+ econf
+ fi
+}
+
+src_compile() {
+ emake -C common || die
+
+ if use kde ; then
+ emake -C kd4 || die
+ fi
+
+ if use gnome ; then
+ emake -C gnome || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C common install || die
+
+ if use kde ; then
+ emake DESTDIR="${D}" -C kde4 install || die
+ fi
+
+ if use gnome ; then
+ emake DESTDIR="${D}" -C gnome install || die
+ fi
+
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+}
diff --git a/app-backup/backintime/files/backintime-1.0.6-wrapper.patch b/app-backup/backintime/files/backintime-1.0.6-wrapper.patch
new file mode 100644
index 000000000000..ff4283e270ef
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.6-wrapper.patch
@@ -0,0 +1,45 @@
+--- backintime-1.0.8/common/backintime
++++ backintime-1.0.8/common/backintime
+@@ -17,11 +17,7 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f backintime.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/common"
+-fi
++APP_PATH="/usr/share/backintime/common"
+
+ python ${APP_PATH}/backintime.py "$@"
+
+--- backintime-1.0.8/gnome/backintime-gnome
++++ backintime-1.0.8/gnome/backintime-gnome
+@@ -17,11 +17,7 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/gnome"
+-fi
++APP_PATH="/usr/share/backintime/gnome"
+
+ python ${APP_PATH}/app.py "$@"
+
+--- backintime-1.0.8/kde4/backintime-kde4
++++ backintime-1.0.8/kde4/backintime-kde4
+@@ -17,11 +17,7 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/kde4"
+-fi
++APP_PATH="/usr/share/backintime/kde4"
+
+ python ${APP_PATH}/app.py "$@"
+
diff --git a/app-backup/backintime/metadata.xml b/app-backup/backintime/metadata.xml
index e13b6746a847..b1f5e35e552f 100644
--- a/app-backup/backintime/metadata.xml
+++ b/app-backup/backintime/metadata.xml
@@ -2,7 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
</maintainer>
<longdescription lang="en">
Back In Time is a simple backup tool for Linux inspired from “flyback project” and “TimeVault”. The backup is done by taking snapshots of a specified set of directories.