summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2004-11-06 00:39:54 +0000
committerStefan Jones <cretin@gentoo.org>2004-11-06 00:39:54 +0000
commit0ff64c7662d7d74b4b1ab78d0a1b667820727a2f (patch)
treefd45a477f3c2306721a4af0e591de93395f22734 /app-arch
parentStable on alpha, bug 70138. (Manifest recommit) (diff)
downloadgentoo-2-0ff64c7662d7d74b4b1ab78d0a1b667820727a2f.tar.gz
gentoo-2-0ff64c7662d7d74b4b1ab78d0a1b667820727a2f.tar.bz2
gentoo-2-0ff64c7662d7d74b4b1ab78d0a1b667820727a2f.zip
Added patch to fix bug #69811
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/ChangeLog5
-rw-r--r--app-arch/rpm/files/rpm-4.2-pic.patch47
-rw-r--r--app-arch/rpm/rpm-4.2.ebuild3
3 files changed, 53 insertions, 2 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index c961648e73c9..44200da0fa53 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/rpm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.39 2004/10/24 01:53:43 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.40 2004/11/06 00:39:54 cretin Exp $
+
+ 05 Nov 2004; Stefan Jones <cretin@gentoo.org> +files/rpm-4.2-pic.patch:
+ Patch so -fpie compiles (ie. gentoo hardened gcc)
*rpm-4.2 (23 Oct 2004)
diff --git a/app-arch/rpm/files/rpm-4.2-pic.patch b/app-arch/rpm/files/rpm-4.2-pic.patch
new file mode 100644
index 000000000000..801775e8624c
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.2-pic.patch
@@ -0,0 +1,47 @@
+--- rpm-4.2/lib/rpmrc.c.jj 2004-11-05 12:14:16.961834816 -0800
++++ rpm-4.2/lib/rpmrc.c 2004-11-05 12:17:43.567425992 -0800
+@@ -892,7 +892,7 @@
+ #ifdef __LCLINT__
+ *eax = *ebx = *ecx = *edx = 0;
+ #endif
+-#ifdef PIC
++#ifdef __PIC__
+ __asm__("pushl %%ebx; cpuid; movl %%ebx,%1; popl %%ebx"
+ : "=a"(*eax), "=g"(*ebx), "=&c"(*ecx), "=&d"(*edx)
+ : "a" (op));
+@@ -912,7 +912,7 @@
+ {
+ unsigned int val;
+
+-#ifdef PIC
++#ifdef __PIC__
+ __asm__("pushl %%ebx; cpuid; popl %%ebx"
+ : "=a" (val) : "a" (op) : "ecx", "edx");
+ #else
+@@ -927,7 +927,7 @@
+ {
+ unsigned int tmp, val;
+
+-#ifdef PIC
++#ifdef __PIC__
+ __asm__("pushl %%ebx; cpuid; movl %%ebx,%1; popl %%ebx"
+ : "=a" (tmp), "=g" (val) : "a" (op) : "ecx", "edx");
+ #else
+@@ -941,7 +941,7 @@
+ /*@*/
+ {
+ unsigned int tmp, val;
+-#ifdef PIC
++#ifdef __PIC__
+ __asm__("pushl %%ebx; cpuid; popl %%ebx"
+ : "=a" (tmp), "=c" (val) : "a" (op) : "edx");
+ #else
+@@ -956,7 +956,7 @@
+ /*@*/
+ {
+ unsigned int tmp, val;
+-#ifdef PIC
++#ifdef __PIC__
+ __asm__("pushl %%ebx; cpuid; popl %%ebx"
+ : "=a" (tmp), "=d" (val) : "a" (op) : "ecx");
+ #else
diff --git a/app-arch/rpm/rpm-4.2.ebuild b/app-arch/rpm/rpm-4.2.ebuild
index abe12fd9f8aa..022f372e25c9 100644
--- a/app-arch/rpm/rpm-4.2.ebuild
+++ b/app-arch/rpm/rpm-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2.ebuild,v 1.10 2004/10/26 16:08:01 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.2.ebuild,v 1.11 2004/11/06 00:39:54 cretin Exp $
inherit python flag-o-matic libtool eutils
@@ -27,6 +27,7 @@ RDEPEND="=sys-libs/db-3.2*
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/rpm-4.2-python2.3.diff
+ epatch ${FILESDIR}/rpm-4.2-pic.patch
}
src_compile() {