summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-07 21:01:36 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-07 21:01:36 +0000
commite8bcd5798ab266e1e78256eff3df87730473ed8e (patch)
tree9d48edab659ea86a367c52c4e23b03dfc6462c08 /app-admin/tenshi
parentMarking gobby-0.4.13 ppc for bug 418563 (diff)
downloadgentoo-2-e8bcd5798ab266e1e78256eff3df87730473ed8e.tar.gz
gentoo-2-e8bcd5798ab266e1e78256eff3df87730473ed8e.tar.bz2
gentoo-2-e8bcd5798ab266e1e78256eff3df87730473ed8e.zip
Version bump (bug 420003 by Brian De Wolf)
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/tenshi')
-rw-r--r--app-admin/tenshi/ChangeLog7
-rw-r--r--app-admin/tenshi/tenshi-0.14.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-admin/tenshi/ChangeLog b/app-admin/tenshi/ChangeLog
index 7b7062a4f90d..55cbc5b27457 100644
--- a/app-admin/tenshi/ChangeLog
+++ b/app-admin/tenshi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/tenshi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/ChangeLog,v 1.70 2012/05/31 02:59:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/ChangeLog,v 1.71 2012/06/07 21:01:36 xmw Exp $
+
+*tenshi-0.14 (07 Jun 2012)
+
+ 07 Jun 2012; Michael Weber <xmw@gentoo.org> +tenshi-0.14.ebuild:
+ Version bump (bug 420003 by Brian De Wolf)
31 May 2012; Zac Medico <zmedico@gentoo.org> tenshi-0.12.ebuild:
inherit user for enewgroup and enewuser
diff --git a/app-admin/tenshi/tenshi-0.14.ebuild b/app-admin/tenshi/tenshi-0.14.ebuild
new file mode 100644
index 000000000000..28882c6c775c
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tenshi/tenshi-0.14.ebuild,v 1.1 2012/06/07 21:01:35 xmw Exp $
+
+EAPI=4
+inherit eutils user
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="http://dev.inversepath.com/trac/tenshi"
+SRC_URI="http://dev.inversepath.com/tenshi/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils"
+
+pkg_setup() {
+ enewgroup tenshi
+ enewuser tenshi -1 -1 /var/lib/tenshi tenshi
+}
+
+src_prepare() {
+ # Fix for bug #241254
+ sed -i 's:^docdir =.*:docdir = /usr/share/doc/${PF}:' \
+ Makefile || die "docdir substitution failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ fowners tenshi:root /etc/tenshi/tenshi.conf
+ dodir /var/lib/tenshi
+ fowners tenshi:root /var/lib/tenshi
+ doman tenshi.8
+ newinitd tenshi.gentoo-init tenshi
+ keepdir /var/lib/tenshi
+}
+
+pkg_postinst() {
+ ewarn "The sample config installed to ${ROOT}etc/tenshi/tenshi.conf"
+ ewarn "monitors /var/log/messages which, by default, can not be read"
+ ewarn "by the tenshi user. Make sure that the tenshi user has read"
+ ewarn "permission on all the files that you want tenshi to monitor."
+}