summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-13 07:27:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-13 07:27:13 +0000
commit3c323a75efdba6ec2500e4534e08dfa5678a63a5 (patch)
tree2a23362878d5941e35cc6f31b19b8f7dff866533 /app-admin/supervisor
parentCleanup. (diff)
downloadgentoo-2-3c323a75efdba6ec2500e4534e08dfa5678a63a5.tar.gz
gentoo-2-3c323a75efdba6ec2500e4534e08dfa5678a63a5.tar.bz2
gentoo-2-3c323a75efdba6ec2500e4534e08dfa5678a63a5.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/ChangeLog8
-rw-r--r--app-admin/supervisor/supervisor-3.0_beta1.ebuild39
2 files changed, 45 insertions, 2 deletions
diff --git a/app-admin/supervisor/ChangeLog b/app-admin/supervisor/ChangeLog
index 6d84b64a3561..83b15b4655cb 100644
--- a/app-admin/supervisor/ChangeLog
+++ b/app-admin/supervisor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/supervisor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.7 2012/08/02 21:29:54 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.8 2012/11/13 07:27:13 patrick Exp $
+
+*supervisor-3.0_beta1 (13 Nov 2012)
+
+ 13 Nov 2012; Patrick Lauer <patrick@gentoo.org> +supervisor-3.0_beta1.ebuild:
+ Bump
02 Aug 2012; Jesus Rivero <neurogeek@gentoo.org>
supervisor-3.0_alpha10.ebuild, supervisor-3.0_alpha12.ebuild:
@@ -37,4 +42,3 @@
+supervisor-3.0_alpha8.ebuild, +files/conf.d, +files/init.d,
+metadata.xml:
Initial version of the package.
-
diff --git a/app-admin/supervisor/supervisor-3.0_beta1.ebuild b/app-admin/supervisor/supervisor-3.0_beta1.ebuild
new file mode 100644
index 000000000000..104ce608603e
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.0_beta1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/supervisor-3.0_beta1.ebuild,v 1.1 2012/11/13 07:27:13 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml(+)"
+SUPPORT_PYTHON_ABIS="1"
+# xml.etree.ElementTree module required.
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ http://pypi.python.org/pypi/supervisor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/meld3
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS="CHANGES.txt TODO.txt"
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}/init.d" supervisord || die "newinitd failed"
+ newconfd "${FILESDIR}/conf.d" supervisord || die "newconfd failed"
+}