summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-11-12 19:40:18 +0000
committerPeter Volkov <pva@gentoo.org>2009-11-12 19:40:18 +0000
commitc1ce0944d8cf399c8cc603d8b8996270ab9a9464 (patch)
treede59bcdcffa29b1f81fb50c5129ea1d85d47dfe9 /app-admin/sshguard
parentPending removal for dazuko in 30 days (diff)
downloadgentoo-2-c1ce0944d8cf399c8cc603d8b8996270ab9a9464.tar.gz
gentoo-2-c1ce0944d8cf399c8cc603d8b8996270ab9a9464.tar.bz2
gentoo-2-c1ce0944d8cf399c8cc603d8b8996270ab9a9464.zip
Version bump, bug #292645, thank Stefan Nilsson for report.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/sshguard')
-rw-r--r--app-admin/sshguard/ChangeLog7
-rw-r--r--app-admin/sshguard/sshguard-1.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-admin/sshguard/ChangeLog b/app-admin/sshguard/ChangeLog
index 04c276c735ba..c975ca56a907 100644
--- a/app-admin/sshguard/ChangeLog
+++ b/app-admin/sshguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sshguard
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.10 2009/03/22 01:51:51 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.11 2009/11/12 19:40:18 pva Exp $
+
+*sshguard-1.4 (12 Nov 2009)
+
+ 12 Nov 2009; Peter Volkov <pva@gentoo.org> +sshguard-1.4.ebuild:
+ Version bump, bug #292645, thank Stefan Nilsson for report.
22 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/app-admin/sshguard/sshguard-1.4.ebuild b/app-admin/sshguard/sshguard-1.4.ebuild
new file mode 100644
index 000000000000..3ecd7c656276
--- /dev/null
+++ b/app-admin/sshguard/sshguard-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.4.ebuild,v 1.1 2009/11/12 19:40:18 pva Exp $
+
+EAPI="2"
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="ipfilter kernel_FreeBSD kernel_linux"
+
+CDEPEND="kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( !ipfilter? ( sys-freebsd/freebsd-pf ) )"
+DEPEND="${CDEPEND}
+ sys-devel/flex"
+RDEPEND="${CDEPEND}
+ virtual/logger"
+
+src_configure() {
+ local myconf
+ if use kernel_linux; then
+ myconf="--with-firewall=iptables"
+ elif use kernel_FreeBSD; then
+ use ipfilter && myconf="--with-firewall=ipfw" \
+ || myconf="--with-firewall=pf"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README Changes || die "dodoc failed"
+ dodoc examples/* || die "dodoc failed"
+}