summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:10:35 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:10:35 +0000
commitb1e358fd8fa614dff7b437c9407efce0f2446072 (patch)
treef14700b17cb123d17e7f93eb883de04ce2839782 /app-admin/puppet
parentadd py3 pypy support (diff)
downloadgentoo-2-b1e358fd8fa614dff7b437c9407efce0f2446072.tar.gz
gentoo-2-b1e358fd8fa614dff7b437c9407efce0f2446072.tar.bz2
gentoo-2-b1e358fd8fa614dff7b437c9407efce0f2446072.zip
fixes for CVE-2014-32[48,50] bug 513284
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/ChangeLog11
-rw-r--r--app-admin/puppet/puppet-2.7.25.ebuild (renamed from app-admin/puppet/puppet-3.5.1.ebuild)85
-rw-r--r--app-admin/puppet/puppet-3.4.2-r1.ebuild164
-rw-r--r--app-admin/puppet/puppet-3.4.2-r2.ebuild165
-rw-r--r--app-admin/puppet/puppet-3.4.2.ebuild162
-rw-r--r--app-admin/puppet/puppet-3.6.0.ebuild189
-rw-r--r--app-admin/puppet/puppet-3.6.2.ebuild (renamed from app-admin/puppet/puppet-3.6.1.ebuild)2
7 files changed, 60 insertions, 718 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index aef39c17a2f0..821f9e3e3c63 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.198 2014/05/24 06:26:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.199 2014/06/15 03:10:35 prometheanfire Exp $
+
+*puppet-3.6.2 (15 Jun 2014)
+*puppet-2.7.25 (15 Jun 2014)
+
+ 15 Jun 2014; Matthew Thode <prometheanfire@gentoo.org> +puppet-2.7.25.ebuild,
+ +puppet-3.6.2.ebuild, -puppet-3.4.2-r1.ebuild, -puppet-3.4.2-r2.ebuild,
+ -puppet-3.4.2.ebuild, -puppet-3.5.1.ebuild, -puppet-3.6.0.ebuild,
+ -puppet-3.6.1.ebuild:
+ fixes for CVE-2014-32[48,50] bug 513284
*puppet-3.6.1 (24 May 2014)
diff --git a/app-admin/puppet/puppet-3.5.1.ebuild b/app-admin/puppet/puppet-2.7.25.ebuild
index 83716b54edea..e428b994fe57 100644
--- a/app-admin/puppet/puppet-3.5.1.ebuild
+++ b/app-admin/puppet/puppet-2.7.25.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.5.1.ebuild,v 1.1 2014/05/14 06:36:08 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.25.ebuild,v 1.1 2014/06/15 03:10:35 prometheanfire Exp $
EAPI="5"
+USE_RUBY="ruby19"
-USE_RUBY="ruby19 ruby20"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
+inherit elisp-common xemacs-elisp-common eutils ruby-fakegem user
DESCRIPTION="A system automation and configuration management software"
HOMEPAGE="http://puppetlabs.com/"
@@ -14,13 +17,11 @@ SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/rgen
- >=dev-ruby/facter-1.6.2
+ >=dev-ruby/facter-1.5.6
augeas? ( dev-ruby/ruby-augeas )
diff? ( dev-ruby/diff-lcs )
doc? ( dev-ruby/rdoc )
@@ -28,29 +29,43 @@ ruby_add_rdepend "
shadow? ( dev-ruby/ruby-shadow )
sqlite3? ( dev-ruby/sqlite3 )
virtual/ruby-ssl"
+# couchdb? ( dev-ruby/couchrest )
+# mongrel? ( www-servers/mongrel )
+# rack? ( >=dev-ruby/rack-1 )
+# rails? (
+# dev-ruby/rails
+# >=dev-ruby/activerecord-2.1
+# )
+# stomp? ( dev-ruby/stomp )
DEPEND="${DEPEND}
ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
+ xemacs? ( app-editors/xemacs )
+ selinux? ( sec-policy/selinux-puppet )"
RDEPEND="${RDEPEND}
ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
+ emacs? ( virtual/emacs )
+ xemacs? ( app-editors/xemacs )
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0"
SITEFILE="50${PN}-mode-gentoo.el"
+RUBY_PATCHES=( )
+
pkg_setup() {
enewgroup puppet
enewuser puppet -1 -1 /var/lib/puppet puppet
}
all_ruby_compile() {
+ all_fakegem_compile
+
if use emacs ; then
elisp-compile ext/emacs/puppet-mode.el
fi
@@ -64,38 +79,35 @@ all_ruby_compile() {
fi
}
-each_ruby_install() {
- each_fakegem_install
- #${RUBY} install.rb --destdir="${D}" install || die
+each_fakegem_install() {
+ ${RUBY} install.rb --destdir="${D}" install
}
all_ruby_install() {
all_fakegem_install
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
newinitd "${FILESDIR}"/puppet.init-r1 puppet
+ doconfd conf/gentoo/conf.d/puppet
# Initial configuration files
insinto /etc/puppet
+ # Bug #338439
+ #doins conf/gentoo/puppet/*
+ doins conf/redhat/puppet.conf
# Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
+ keepdir /var/{run,log}/puppet
+ fowners -R puppet:puppet /var/{run,log}/puppet
if use minimal ; then
+ rm "${ED}/usr/bin/puppetmasterd"
rm "${ED}/etc/puppet/auth.conf"
else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
+ newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
insinto /etc/puppet
+ doins conf/redhat/fileserver.conf
keepdir /etc/puppet/manifests
keepdir /etc/puppet/modules
@@ -103,11 +115,8 @@ all_ruby_install() {
keepdir /var/lib/puppet/ssl
keepdir /var/lib/puppet/facts
keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet
fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
if use emacs ; then
elisp-install ${PN} ext/emacs/puppet-mode.el*
@@ -123,10 +132,16 @@ all_ruby_install() {
insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
+ fi
+
# ext and examples files
for f in $(find ext examples -type f) ; do
docinto "$(dirname ${f})"; dodoc "${f}"
done
+ docinto conf; dodoc conf/namespaceauth.conf
}
pkg_postinst() {
@@ -134,8 +149,13 @@ pkg_postinst() {
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
elog
if [ \
@@ -151,13 +171,6 @@ pkg_postinst() {
elog
fi
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen
}
diff --git a/app-admin/puppet/puppet-3.4.2-r1.ebuild b/app-admin/puppet/puppet-3.4.2-r1.ebuild
deleted file mode 100644
index 26c6f4ee1c83..000000000000
--- a/app-admin/puppet/puppet-3.4.2-r1.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.4.2-r1.ebuild,v 1.1 2014/01/15 19:07:03 prometheanfire Exp $
-
-EAPI="5"
-
-#supports ruby20, but needs deps first
-USE_RUBY="ruby19"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/facter-1.6.2
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.4.2-r2.ebuild b/app-admin/puppet/puppet-3.4.2-r2.ebuild
deleted file mode 100644
index 9fa543c6a14c..000000000000
--- a/app-admin/puppet/puppet-3.4.2-r2.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.4.2-r2.ebuild,v 1.1 2014/02/18 04:01:28 prometheanfire Exp $
-
-EAPI="5"
-
-#supports ruby20, but needs deps first
-USE_RUBY="ruby19"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/rgen
- >=dev-ruby/facter-1.6.2
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.4.2.ebuild b/app-admin/puppet/puppet-3.4.2.ebuild
deleted file mode 100644
index 7e51893b203d..000000000000
--- a/app-admin/puppet/puppet-3.4.2.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.4.2.ebuild,v 1.1 2014/01/08 16:07:57 prometheanfire Exp $
-
-EAPI="5"
-
-#supports ruby20, but needs deps first
-USE_RUBY="ruby19"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-ng versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/facter-1.6.2
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.6.0.ebuild b/app-admin/puppet/puppet-3.6.0.ebuild
deleted file mode 100644
index 17f17d76218a..000000000000
--- a/app-admin/puppet/puppet-3.6.0.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.6.0.ebuild,v 1.1 2014/05/18 19:47:36 graaff Exp $
-
-EAPI="5"
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://www.puppetlabs.com/downloads/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/rgen-0.6.5 =dev-ruby/rgen-0.6*
- >=dev-ruby/facter-1.6.2 <dev-ruby/facter-3
- dev-ruby/json
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # Avoid Rails specs to avoid this dependency and because they
- # currently fail against Rails 4.1.
- find spec -type f -name '*rails*' -o -name '*active_record*' | xargs rm || die
- rm -r spec/unit/rails || die
- rm spec/unit/parser/collector_spec.rb || die
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb spec/integration/parser/future_compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- #${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.6.1.ebuild b/app-admin/puppet/puppet-3.6.2.ebuild
index fa9570aa3c2b..9efd93b30133 100644
--- a/app-admin/puppet/puppet-3.6.1.ebuild
+++ b/app-admin/puppet/puppet-3.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.6.1.ebuild,v 1.1 2014/05/24 06:26:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.6.2.ebuild,v 1.1 2014/06/15 03:10:35 prometheanfire Exp $
EAPI="5"