summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 15:12:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 15:12:43 +0000
commitb6fc5926e52f896ae2e01a5e34be0afaba5d381b (patch)
tree038aa12b1d62e21aa276fae5a2a67073a0399e31 /app-accessibility
parentgnome-base/librsvg will be needed by apps using this icons, bug #508210 by Se... (diff)
downloadgentoo-2-b6fc5926e52f896ae2e01a5e34be0afaba5d381b.tar.gz
gentoo-2-b6fc5926e52f896ae2e01a5e34be0afaba5d381b.tar.bz2
gentoo-2-b6fc5926e52f896ae2e01a5e34be0afaba5d381b.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog8
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index 5b2b95c63064..e7ddea16efae 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.62 2014/04/23 20:27:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.63 2014/04/27 15:12:43 eva Exp $
+
+*at-spi2-core-2.12.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +at-spi2-core-2.12.0.ebuild:
+ Version bump for Gnome 3.12.
23 Apr 2014; Pacho Ramos <pacho@gentoo.org> -at-spi2-core-2.6.3.ebuild,
-at-spi2-core-2.8.0.ebuild:
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild
new file mode 100644
index 000000000000..2fef01eb1410
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild,v 1.1 2014/04/27 15:12:43 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=sys-apps/dbus-1
+ x11-libs/libSM
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ gnome2_src_configure \
+ --disable-xevie \
+ $(use_enable introspection) \
+ $(use_enable X x11)
+}