summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2014-08-06 18:24:15 +0000
committerIan Whyman <thev00d00@gentoo.org>2014-08-06 18:24:15 +0000
commitd536e03a708a0134b3b909b3c2be3a4498bddb76 (patch)
treecf5a6b356973d0151633b9f4d4bd2972895adab5
parentVersion bump wrt bug #518470. Thanks to Andreis Vinogradovs (diff)
downloadgentoo-2-d536e03a708a0134b3b909b3c2be3a4498bddb76.tar.gz
gentoo-2-d536e03a708a0134b3b909b3c2be3a4498bddb76.tar.bz2
gentoo-2-d536e03a708a0134b3b909b3c2be3a4498bddb76.zip
Bump to 1.0.1, fixes #501532, #509642 and #516414
(Portage version: 2.2.11-r1/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--app-emulation/virt-manager/ChangeLog8
-rw-r--r--app-emulation/virt-manager/virt-manager-1.0.1.ebuild87
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild10
3 files changed, 98 insertions, 7 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index 8240a13e4d9a..0fe3701dffc8 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.105 2014/08/06 17:50:43 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.106 2014/08/06 18:24:15 thev00d00 Exp $
+
+*virt-manager-1.0.1 (06 Aug 2014)
+
+ 06 Aug 2014; Ian Whyman <thev00d00@gentoo.org> +virt-manager-1.0.1.ebuild,
+ virt-manager-9999.ebuild:
+ Bump to 1.0.1, fixes #501532, #509642 and #516414
06 Aug 2014; Ian Whyman <thev00d00@gentoo.org> virt-manager-9999.ebuild:
Sync 9999 with latest stable, add missing sys-libs/libosinfo RDEPEND per
diff --git a/app-emulation/virt-manager/virt-manager-1.0.1.ebuild b/app-emulation/virt-manager/virt-manager-1.0.1.ebuild
new file mode 100644
index 000000000000..c26da3790663
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-1.0.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-1.0.1.ebuild,v 1.1 2014/08/06 18:24:15 thev00d00 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical tool for administering virtual machines"
+HOMEPAGE="http://virt-manager.org"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.fedorahosted.org/virt-manager.git"
+else
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gnome-keyring gtk policykit sasl"
+
+RDEPEND="!app-emulation/virtinst
+ || (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ >=app-emulation/libvirt-0.7.0[python(-),${PYTHON_USEDEP}]
+ )
+ >=app-emulation/libvirt-glib-0.0.9[introspection,python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ sys-libs/libosinfo[introspection]
+ gtk? (
+ x11-libs/gtk+:3[introspection]
+ gnome-base/dconf
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection]
+ net-misc/spice-gtk[gtk3,introspection,python,sasl?,${PYTHON_USEDEP}]
+ x11-libs/vte:2.90[introspection]
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ policykit? ( sys-auth/polkit[introspection] )
+ x11-themes/gnome-icon-theme
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool"
+
+DOCS=( README NEWS )
+
+distutils-r1_python_compile() {
+ local defgraphics=
+
+ esetup.py configure \
+ --qemu-user=qemu \
+ --default-graphics=spice
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_fix_shebang \
+ "${ED}"/usr/share/virt-manager/virt-{clone,convert,image,install,manager}
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_pkg_preinst
+
+ cd "${ED}"
+ export GNOME2_ECLASS_ICONS=$(find 'usr/share/virt-manager/icons' -maxdepth 1 -mindepth 1 -type d 2> /dev/null)
+ else
+ rm -rf "${ED}/usr/share/virt-manager/virtManager"
+ rm -f "${ED}/usr/share/virt-manager/virt-manager"
+ rm -rf "${ED}/usr/share/virt-manager/ui/"
+ rm -rf "${ED}/usr/share/virt-manager/icons/"
+ rm -rf "${ED}/usr/share/man/man1/virt-manager.1*"
+ rm -rf "${ED}/usr/share/icons/"
+ rm -rf "${ED}/usr/share/applications/virt-manager.desktop"
+ rm -rf "${ED}/usr/bin/virt-manager"
+ fi
+}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index fa92bfe3ad67..b1f4fc9e6f18 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.21 2014/08/06 17:50:43 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.22 2014/08/06 18:24:15 thev00d00 Exp $
EAPI=5
-BACKPORTS=1cd29748
-
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
@@ -20,8 +18,7 @@ if [[ ${PV} = *9999* ]]; then
KEYWORDS=""
EGIT_REPO_URI="git://git.fedorahosted.org/virt-manager.git"
else
- SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
- ${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -44,11 +41,12 @@ RDEPEND="!app-emulation/virtinst
gtk? (
x11-libs/gtk+:3[introspection]
gnome-base/dconf
- >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}]
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection]
net-misc/spice-gtk[gtk3,introspection,python,sasl?,${PYTHON_USEDEP}]
x11-libs/vte:2.90[introspection]
gnome-keyring? ( dev-python/gnome-keyring-python )
policykit? ( sys-auth/polkit[introspection] )
+ x11-themes/gnome-icon-theme
)"
DEPEND="${RDEPEND}
dev-lang/perl